Multiple Maps On Computer

Cannot install multiple maps from on computer, only on DEVICE. Installing first map on Windows 7, running osm_generic_windows.exe, is no problem. Installation folder is named unique. Map is renamed unique, in FID and Name on Computer and in registry, by running JaVaWa GMTK. Attempting second map installation on computer, running osm_generic_windows.exe, produces message “OSM generic routable is already installed. Click ‘OK’ to remove the previous version…” Proceeding does unfortunately remove previous map. Note “OSM generic routable” is still the map’s name, somewhere internally.

I would suggest to use the Mac version (gmap format). You can use GMTK to install it on your windows pc, and have to change name and map id but this version does not need an installer or windows registry.

Hey, that worked! Details:

You really did mean the “Mac version”\OSM generic routable.gmap\ folder, not for example the gmapsupp.img! I first renamed that folder “OSM South America.gmap”. Then I uninstalled my previous map by Control Panel, and noted the program name “OSM generic routable”, non-unique names explaining the problem with installing multiples by _windows.exe. I then installed my first map on PC (at Program Data\Garmin\Maps\OSM South America) from its .gmap by GMTK. Then renamed it unique (FID and names, by GMTK). Then installed a second map (second continent) from its renamed .gmap\ folder by GMTK - success! - and renamed it unique. Then a third continent similarly. Total success.

Remember from my first post, this is installation on computer. Installation on device was simply by renaming gmapsupp.img to gmapsupp1.img or -2.img etc., editing it for display name (in bytes 49 etc. by hex editor XVI32, name to appear on device), and copying it to a Garmin\ folder on SD card.

Glad that it worked :slight_smile:
Yes, the Mac version, gmap, not confuse this with gmapsupp. On a Windows PC this gmap is copied to a -often hidden- garmin directory. Thats all, no installation needed. To uninstall the map just delete the gmap folder.