mkgmap in windows can't open style-file

On a linux computer I’ve got mkgmap version 1953 running with my own custom style.

I’ve got the necesarry files (version, lines, points, etc.) in a directory called “allroadmap”. I invoked the style with the options --style-file=allroadmap --style=allroadmap. It works this way on my linux computer.

Now I’m trying to set up mkgmap version 2012 on a spare windows vista laptop in the same way. In the mkgmap directory I created a “allroadmap” directory. Again I use --style-file=allroadmap and --style=allroadmap but it keeps saying: “Could not open style allroadmap”.

Maybe you need to specify the path to the directory like --style-file=c:\mkgmap\allroadmap
BTW Why do you need two --style= and --style-file= arguments? One --style-file should be enough

I tried it all. Forward slashes, backward slashes, trailing slashes, complete paths. Only --style or --style-file, or a combination of the two in different orders. I can’t get it to work. I Just downloaded r2012 on my linux computer and I don’t have any problems.

Am I the only one who uses mkgmap with a custom style on a windows computer?

Nope! Here’s my batch file:

@echo off
REM Batch file to launch mkgmap and compile tiles 

REM set mkgmap version
set mkgmapVer=-r1970

REM set inputs
set stylefile=../../../styles/CF_Mapsource
set optionsFile=options_GCC_Mapsource.args

REM TYP file
set typfile="../../../TYP files/Charlie/CF1423.TYP"

REM run mkgmap
@echo on

java -Xmx1500m -ea -jar ../../../mkgmap/mkgmap%mkgmapVer%/mkgmap.jar --style-file=%stylefile% -c %optionsFile% %typfile%

@echo off

echo Finished!!!


I didn’t notice that notepad automaticaly adds a .txt extension :frowning:

I don’t think Notepad does that but your Windows. Better use notepad++ for editing the style files and something like Total Commander for file management because the default windows programms sucks.

By the way, the --style=foo option only works to select one of the pre-built mkgmap styles that “live” inside the mkgmap.jar file. You cannot use it to select one of your own styles (this is what --style-file=foo is for).