MapSetToolKit Supported?

AFAIK the only way of combining mkgmap generated IMG files into a TDB is to use mkgmap, although Sendmap 2.0 can also be used to create a gmapsupp.IMG.

Although MapSetToolKit works with cgpsmapper compiled IMG files, it is not a viable option with mkgmap compiled files. I see a lot of questions in other groups where users are having difficulties trying to mix and match IMG files from both compilers using MapSetToolKit.

Is there a central location like where they could be warned of the difficulties?

I use MapSetToolkit to install mkgmap-generated maps in MapSource. So at least for this, it works fine.

If one can point me to specific clearly described information about the things that do not work or how to work around them, then I’ll put it on the site.

I haven’t tried to use it for a while, so maybe I’m just out of date. What’s the earliest version of mkgmap you were able to use MapSetToolKit with?

A sample of intermittent problems with MapSetToolKit and Sendmap 2.0 is discussed at the bottom of this thread:

My only reliable workaround has been to use mkgmap to generate basemap TDB and IMG files. After that its either write an NSIS installer, or overwrite TDB and IMG files of the same name for an already installed map product.

Hmmm - it’s not clear to me what problems people are actually having. The only bit of MapSetToolKit (MSTK) I use is the bit on the bottom right, where you select a TDB file, an overview map, an (optional) TYP file, then click the Install button. Whereupon it just edits the registry so that MapSource knows that the map exists. This has worked flawlessly ever since I discovered MSTK, which must have been about 6 months ago. I have my system set up so that I only need to install a given map (with Family ID=X) once. When I download new OSM data and update the map, mkgmap just overwrites the old .img and .tdb files. But I don’t have to re-install to MapSource as the registry is still pointing to the same directory and the (new) files have the same names as before.

I haven’t tried to install (to MapSource) maps with multiple layers - perhaps this is where people are getting unstuck?

Obviously, csdf, I’m going to have to do some systematic study on MapSetToolKit.

The problem I had, about a year ago, was that I couldn’t get cgpsmapper to run a cpreview with mkgmap generated IMG files. I haven’t tried to use it to just make registry settings, but from what you say works fine, and that makes sense, since its just doing the same job as an NSIS installer.

Pretty much what I said above, but, although generating TDBs using MapSetToolKit for mkgmap compiled IMG files always ends with an “Convert Failed” message, as csdf said, mkgmap generated basemap.TDB and basemap.IMG files can be installed into MapSource using the “Install” Button in MapSetToolKit.

Mkgmap IMG users who also use MapSetToolKit should be warned of its limitations as well as its potential.

Out of curiosity, why use MSTK to generate TDB files when mkgmap can do it?

Well, since it doesn’t work, it doesn’t make much sense. But it’s one of the standard ways to install cgpsmapper generated IMG files so people try to do it because they have an IMG file and don’t know whether it was generated by cgpsmapper or mkgmap.

I expect that was the problem ger4rd was having in the link I posted above.