MapInstall only passes partial mapping to GPS

I have downloaded the New Style map of Switzerland (CHE) in to BaseCamp on a Windows 10 HP Laptop.

In BaseCamp it all looks fine.

When I use MapInstall to transfer it on to my Garmin Montana 600, only a basic version of the map is installed (more like a base map).

Instead of the GPS receiving the 221 Mbyte map, I only get about 11 Mbytes with no detail and most searching giving no results.

I have tried this 6 times and also tried with the “old” Style mapping. Both give the same problem.

This problem has never occurred in the past. I wondered if Garmin are now blocking Third Party maps.

I am taking 15 members of a Walking Group to Switzerland next week, so any help would be most appreciated.


Roy Turner

Roy, unfortunately the latest Garmin Mapinstall is corrupt, they are not blocking 3rd party maps but released a buggy update.
You’ll have to downgrade Basecamp to 4.6.2. See

Strangely, when I select a number of tiles which include the whole of Switzerland and parts of France, the whole of the map successfully installed into my GPS.

I used the maps extensively whilst our walking group was over there and they worked perfectly.


Roy Turner