Map only visible at some zoom levels (newbie question)

I am a newbie so any help would be very welcome :smiley: please.

I am finding that a bit of map I have added is only visible at some zoom levels.

This shows ok

This does not

Have I done something wrong?
I have been watching this for a couple of days now, but it remains the same.


Hi, slight change today :slight_smile:

Zoom level 13 works, but zoom 14 does not

I am reading that the tiles should render within a fairly short time, any suggestions why the area I am looking at is so very sluggish to display please?

I have been looking at the FAQ

but I don’t see anything that explains what I am seeing.


The map on renders only once a week, so you won’t find any changes there quickly. If you want to see your changes in a matter of a few hours then please visit the map at (Zoom in to level 12 and ctrl-left click to request a re-render of a certain area).

Why the map has a missing tile on that position is a mystery to me. It will probably be ok next wednesday/thursday.

The mapnik tiles render when viewed, but only at max once every 3 days. The source is usually updated once a week (wednesday). So some of the tiles that don’t appear to have updated to show your edits, will have been updated shortly (0-3days) prier to you making your edit, as you or someone else would have viewed them. I avoid zooming in on any tiles around me from sunday onward just so I can see the edits on wednesday!..that won’t work for much longer as more and more poeople start checking out the maps.

Thanks for the additional information, the renederings are great.
I thought it best to show a bit more patience and wait so see how the changes I have done shake down :slight_smile:

I have added most of the ways on this view

I understand how long it takes for changes to appear on the main map, but I still dont understand why parts of the map are missing at some zoom levels where there have been no changes for a couple of weeks, like the middle of this view


I have seen places where some high zoom tiles are quite a long way behind. But usually if you add /dirty to the end of the address (when you view the mapnik tile by itself) it should force a fresh render. Plus have you checked you are fully refreshing the page?

Hi Ben,
Thanks for the Tips,
Pretty sure I am reloading the page (at least some of the time, e.g. first logon after PC rebooted I think?)

This is a tile that doesnÂ’t seem to be available right now

I tried

and got the response:
Tile was already on list to be rendered

although I donÂ’t believe that tile has been changed for a couple of weeks, & it has existed for at least 3 weeks.

I have looked at other tiles that should have WAYs on them for ages, e.g. the A3 & chunks of it are still not showing up at high zoom.

I tried another spot picked at random, the M1 junction by Northampton & that has no tiles at high zoom either.

Perhaps I should just concentrate on getting new data & see if it sorts its self out in a while, although it would be nice to see the map working at all zoom levels :slight_smile:


I think I may have found the answer here:

it says
Tiles which haven’t been viewed in 28 days or more (1 month) are automatically deleted daily.

So this is only a map for people who know where the roads would be if they had been rendered & also assumes they have time to wait for the tiles to be rendered. :wink: (been watching my test tile for 100mins so far)

I supose what we need are more disk space so all the work rendering tiles can be kept for browsing at any time. (should also save server processing time for rendering tiles that have changed)

Although we may appreciate the limitations that exist other potential users of will just get the impression that it dosn’t work properly I fear.


Interesting you picked the M1 junction by Northampton, because I mapped that! woo! I hadn’t noticed that it wasn’t showing up, and looking again at it now, all the tiles appear to be there on both levels, although this may be because you went to view them and it therefore requested a render as the tile wasn’t available. T@H keeps all tiles indefinitely as far as I know, so I’m not sure why Mapnik doesn’t also. Personally I would prefer to see the old data, rather than a blank tile, or in Informationfreeway’s case a splattering of blue.

Currently tiles may vanish frequently, but hopefully in the not too distant future tiles going 28 days without being looked at will become rather rarer, as the amount of people using/viewing osm increases.

Apparently (currently) if a tile is picked up automatically for rendering, and you then also do a manual request, that cancels the request (just found that out). That’s a problem that’s being worked on though. The wait time is also quite high for recently changed tiles apparently, but that is also being worked on.

Basically I think the concerns that you have noticed have been noticed by the people that can fix them also, which is good.