Login problem: "primary email has already been taken" on one of two computers

I’m having a very similar issue.
“primary email has already been taken”
In my case I’m trying to login to the community on a new computer. I can login to openstreetmap.org on the new computer, and I can login to community & osm on old computers.
I’ve cleared the cache for openstreetmap.org
On OSM, my account email is *.com, on community it shows a ‘primary email’ which is *.us and oauth2 email which is the *.com email.
Should I revoke access to community on the OAuth 2 setting page?

I’m losing ground.
On my working computer I went to the setting under openstreetmap.org and revoked the oauth2 community.osm access. I logged out of community.
On the new laptop I tried again, same result.
Back on the old reliable desktop, now I can’t login to community, same error msg, “Primary emai has already been taken”
I have another laptop which which is still working

Can you explain what buttons you are pressing in what order, perhaps with screenshots?

Say things like "in a new incognito browser window I browse to osm.org, click “login”, enter the userid and password and then click “login”. Then I browse to https://community.openstreetmap.org/ click “login” fill in the fields on the “Welcome! Let’s create your account” screen and click “Create Your Account”

Let us check, because other user had a similar issue recently, and I see you also have duplicated account @bradrh and @bradrh

Can you send a private message to @forums-governance team with the email you use to login on OSM so we can fix it?

Thanks!

1 Like

I open a new private browser window (firefox), browse to community.openstreetmap.com, click login, enter my username and password. It fails with the error msg “primary email has already been taken”

If I don’t use a private browser window, even tho I’ve cleared the cookies and site data for osm I click login, then I get the error msg & don’t get the window for user name or password

I’ve been using community, so I don’t need a new account.

I’ve sent a PM to nukeador.

1 Like

Yes bradrh1 was an imported forum account. I’ve merged it with @bradrh now which should fix the problems.

2 Likes

@TomH I am encountering the same issue. Are you able to merge the forum account I unknowingly created with my OSM account. My OSM account is eneerhut and I was able to login after appending +osm to the email address associated with my OSM account.

Thank you!

I’ve merged your other account

Much appreciated @pnorman!