Less detail on Garmin maps?


When I view an area on www.openstreetmap.org via a web browser, I can see certain trails that I’m interested in. They are also on the www.wikiloc.com site that apparently uses the OSM service.

When I download the same area from garmin.openstreetmap.nl and view the map in BaseCamp, I cannot see these trails.

However I was told that site updates regularly. Is this a matter of layers/overlays? I’m utterly confused why I can’t get the same level of data in BaseCamp (and therefore on my device) that I can when I use the OSM data on the web.

Any hints welcome.

Make sure you don’t have the base map selected (ctrl-G), select the right map and set the detail level higher.

I needed to

  • Right click on the toolbar in Basecamp
  • Select “Detail Level” from the pop-up menu
  • Select “Highest” from the drop-down that now appeared at the left of the toolbar.
    Way to make things intuitive for a product every single user with a Garmin device needs…

Topic: http://www.openfietsmap.nl

Ok, that works in Basecamp. On my Garmin Etrex I have to go to 200m to see some tiny trails. Other maps are much better for tiny trails.

And, unfortunately openfietsmap.nl works with a very small amount of different types compared to other osm maps. (at least at openfietsmap lite)

You are free to use other maps hoppi. Openfietsmap is originally developed for the Netherlands for recreational non MTB cycling, hence the less details on lower zoom levels and less information about unpaved tracks, I agree that in big areas with fewer roads my maps are not optimal.

@hoppi4 Also on the Garmin device, you can change the details setting. Don’t know for Etrex, on Oregon 600 it’s (translated from German):

  • Settings → Map → Advanced → Details
    On the Oregon, there are 5 levels of details.