JOSM using Mac

I´m using Imac and trying to get JOSM run smoothly. When I log in to OSM and try starting JOSM as editor I´m told that I´m not remote connected even if even JOSM is preset as remote. I´m using my standard browser Safari.
Is there any Apple user out there that can tell how to use JOSM as I´m frequently nudged in that direction?

Assuming that JOSM is running without problems as a ‘standalone’, did you set the preferences inside JOSM to accept remote control?

JOSM running OK as standalone when using Firefox, not running at all with Safari. Yes, preference inside JOSM is set to remote control.

Does this mean that:

  1. JOSM has been started
  2. you run in Firefox
  3. you click on edit in Firefox
  4. JOSM now takes over and you can edit

works in all 4 steps with Firefox, but fails in Safari?

Sorry, when JOSM is standalone I don´t use any browser. When logging in to OSM with Safari and open with JOSM as editor I receive error message that remote is not possible (even when preference inside JOSM is set to remote).
But when using Firefox as browser I can do all 4 steps.

The remote control is made to have a connection from the browser to JOSM (send a command to JOSM to load a given object and/or area). Today this is done with https. For https it needs a certificate in JOSM. As far as I know, this certificate is not from the well known authorities the browsers know.

You can use the following URLs in Safari to ask JOSM for its version via https and accept the connection via https as an exception:

I don’t have a Mac here, but in theory this could be the reason, why it doesn’t work on your Apple computer.


Thank you Franz,

I tried these URLs, but Safari just tell me that it cannot connect to this server. Do I have to make some others adjustments? I see that one can edit a list of site exceptions in the Java Control Panel. I have never touched it, so the list is empty. Do I put the URLs in there?

JOSM has to be started before you can use these URLs. JOSM will open port 8112 as a server to receive commands via https.

I didn’t change anything in the Java Control Panel.


I do it once more:

  1. Started JOSM.
  2. Opened Safari and added an new tab.
  3. Copied in the first URL and so enter.
  4. Safari responded with cannot open the page https://localhost:8112/version and cannot connect to the server localhost.

Sorry I´m stuck.

I have problems with HTTPS remote control on Ubuntu for some time, so I just view the maps with HTTP and it works:


When I tried running JOSM and open Safari with Administrator´s HTTP Url I got this response from Safari: {“protocolversion”: {“major”: 1, “minor”: 7}, “application”: “JOSM RemoteControl”}

So I´m still stuck.

Looking back on the conversations I might been a bit imprecise. When saying that Firefox works fine, it is in the situation that I´m at the website using Firefox and mapping a tile in a project. Then I can use JOSM as editor. However, using Safari I´m dismissed with a warning to arrange remote control.

Any particular reason why you want to use Safari?
I’m a mac user since the Apple Lisa, but I never use Safari and stick with Firefox.

Oh, this is just a clear test if JOSM is listening on HTTP - great, it really is! Actual usage is very simple - keep viewing the map through the HTTP not HTTPS (go to ) and when you want to edit, just click “Edit” button when JOSM is running. If you have set JOSM as default editor in your account preferences, JOSM will simply open this area, otherwise you have to open the list on the right (under the arrow) and choose JOSM, because default is iD.

In my case JOSM does not open port 8112 at all, it has nothing to do with SSL certificates.

When I do as described by Administrator is run smoothly using Safari!!
When I try using httpS however, I get the message that remote control is not enabled. Looking at the sertificate it is issued by Let´s Encrypt Authority X3.
For me - problem solved - and I can use JOSM with standard Apple browser Safari.

What changes do I have to make in JOSM (and elsewhere) if I prefer to run JOSM remotely logging into to secure OSM site?
Right now the JOSM preferences are set to Basic Authentication and remote control ticked.

I think it was described above already somewhere. You need to make Safari accept JOSM’s SSL certificate. As it is not signed by any of the standard authorities Safari probably rejects it. Not being a Safari user I cannot tell you how to accomplish that. Did you try the install certificate option on the remote control preferences page in JOSM?

Tried now to use the OAuth alternative, but in in the authentification process the Accept Access Token button is grey, so I cannot get my authentification.
After downloading JOSM some weeks ago I opted out of the OAuth process and chose Basic authentification.
How can I fix this?

Hi, I’ve browsed to those URLs and accepted the certificate in Safari. I get a webpage with the following info:

{"protocolversion": {"major": 1, "minor": 8}, "application": "JOSM RemoteControl"}

Still, I get en error message when trying to editing with Remote Control:

And it seems to be no longer possible to browse to OSM with unsecured connection (i.e. plain HTTP)–I’m redirect to the HTTPS URL. So I’m basically stuck.

Sorry if this is a stupid question: Why is this feature essential for you? I use it from time to time and sometimes it doesn’t work. I never cared much and simply copied the url to open it in JOSM. That always worked for me (on Windows).