JOSM: Pre-determine Bound Box on open edit set

Yesterday created, by accident, an edit set, 20km high and 150 wide because I somehow managed the set a node without tags. at the east end causing this blue box

Do remember in arrears when this came about, a sudden long red line appearing from off screen and escaping out.

Disturbingly JOSM did not tell me about this untagged lone node on prepping upload and CS commentaries… a clean Validation Results pane, coming back to “If” we could determine what area the CS will cover before uploading. Sometimes when I know there was a large area in which edits were done the possibility to select smaller zones and then Upload Selection (Ctrl+Shift+Alt+U if you can remember), learning from that the relations worked on wont be uploaded until the last edits are send to the server.

Looked at ChangeSet Manager (Ctrl+Alt+C) in hopes there would be, but obviously not, searched for an option to select all changes to visualize to all touched, looked at the upload pane which lists all changes, but nothing obvious to me the shows the BBox or allows to select all edited nodes and do a zoom to selection like the below snip. Would not allow me.


Pretty please, does this exists in some form or does it need a feature request ticket?


You can do a CTRL+F search for “modified” and then a “zoom to selection” (3). Or save an inverted filter for this in the filters panel then just toggle it and select all to get the modifications.

Well, kind of tough to answer all questions but I try:

With current latest release I still get the warning about large BBox in the Upload Dialog. There is an advanced preference to set which area should be considered large:
upload.max-area with default 3.0

How about searching for modified objects (do not forget to check the box for “all objects” in case of deletions) and then “zoom to selection” (keyboard shortcut: 3)?

I still get the warning about an unconnected plus untagged node as long as it is inside the downloaded area or there is no downloaded area at all. Only if the node is outside the downloaded area there is no warning created. I am not sure why this difference is made in this case but overall this behavior is quite common, see #19008 (Differences in results outside downloaded area between no download area at all and small download area somewhere) – JOSM.
In my eyes, there should not be a difference for modified nodes so, please, create a new ticket.

By default JOSM will warn about large bounding boxes and not tagged nodes.

Maybe you have silenced this warnings

No, this is still relatively small, but way too big for my liking. Not heard of large BBox warnings, maybe continent sizes do? The tagless nodes normally warn but here it did not for unknown reason.

Think we have a Bingo. Will store the trick under a toolbar button and test on next (big) outing.


Did a dozen patches in park I’m ‘detailing’, zoomed in on one object, did the Ctrl+F + modied, hit ‘zoom to selection’ + 3 and presto pronto

Toolbar button created, tugged nicely next to the upload button



@Mateusz_Konieczny , created a tagless node on purpose and this is the warning on Ctrl+Shft+U (upload).


A raw suspicion is a node erroneously set in an another data layer I finished working in… often got 3-4 loaded.

Thanks, found the 'upload.max-area=3.0 and a balloon showing it’s default, but what does the value stand for… countries, continents?

A node outside the download zone sure it was for the active edit set. On another data-layer in background did have that farther region loaded.

Got now 4 custom search buttons on the toolbar. Concatenating those tests would be a boon, recollecting one commenter noting that it was possible to create a local validation set. Need to dig that comment and function out.

Thanks again.

OT\ As knock on from @Mateusz_Konieczny comment above in the cause of testing the various tips came upon a reproducible bug, for me, v.v. the shaded areas one sees in JOSM for zones for which data has not been downloaded and the case of nodes created in non-downloaded areas not being considered for validation testing.

  1. Create a blank layer in JOSM with Ctrl+N.
  2. Go to Osmose and search for a pin relating to building flagged as being on agricultural land.
    Sample relation link: Relation: 16793121 | OpenStreetMap
    Sample building link: Way: 187554604 | OpenStreetMap
    (oops you’re seeing the JOSM remove control port too :).
  3. Select the JOSM link on the relation line to open in JOSM launching the action with an active remote control (either select yes-always or yes-once), upon which the polygon or MP relation outline will be loaded into JOSM, whole or part. The farming land outline will show, whole or part in JOSM, no shading, this test case the whole appearing showing in a light green. If not, open the relation editor and fetch all outline parts.
  4. Go back to browser and select the JOSM link for the building, do same as step 3). The building data is fetched and appears in the data layer where red arrow was drawn,

    Close up, still no shading to indicate what was loaded and what not.
  5. Download a small section around the farmyard not yet mapped. Now all mapped buildings appear and the shading around it.

Problem: One could be mistaken into starting to map the other 2 buildings not seen mapped in image point 4 and the landcover when in fact it already was except for the missing farmyard and the assignment of an inner role in the farmland relation.

If someone could kindly test if reproducible, I’ll raise a ticket in JOSM Trac, with link to this comment (posting images there not as easy as here, at least not figured out how but to archaically upload images to e.g. dropbox and then link them at JOSM Trac, sorry.