JOSM issues, slow downloads, system hangs, etc

I have been having many issues with JOSM since yesterday. I had been running v19097 since it was released with no problems at all. Then suddenly it became unusable, hanging on loading imagery preferences to the point that I had to kill the JOSM instance in Task Manager.

I was running Java v8 from Oracle that I have used for years but came across a forum post that said v11 was now required so I removed Oracle v.8 and installed the new v11. Eventually, I got JOSM running again and it loaded and started normally but it exhibited glacially slow download times when fetching OSM data. In addition, when I went to the normal JOSM download site to get a later release, the download took hours to complete! Usually, they take mere seconds.

I finally got the latest version of JOSM, v19039, and it refuses to complete a download of OSM data. I killed it and am now waiting again for an older version to try - the download window tells me it will take 2.5 hours for this 76 MB file. What’s going on?

My Internet connection is fast (I tested it), and I’ve tried several browsers (Firefox, Chrome, Edge), but it seems everything JOSM-related has slowed down massively. I’m running a fully updated Windows 10 on a fast laptop. on

Another related question. In looking at the download choices on ths page the filenames have java17 them, e.g., osm-setup-18969-java17.exe. Should I be running java17?

Is this a problem with only my setup or is anyone else seeing this?

Tangentially, I am also encountering problems with the OSM web iD editor as well. For some reason, recently the iD editor just would not load. Like, the part of the screen which should be the iD editor is blank and white.

At the same time, I noticed the History section on OSM was listing several changesets which entirely covered the city that I was trying to edit. Further checking of the changenotes revealed some sort of large regional/global changesets being pushed and reverted, with nothing specific to the city in question.

My guess is that the several large changesets have somehow jammed the OSM servers and now everything slows down to a crawl. There are now several OSM edits that I cannot do simply because the editor is not loading correctly.

Something is going on.

Edit: I am struggling to load the Nominatim status page Nominatim Demo , might be related

That is very tangential, if not to say off topic, there was a spat of vandalism last week that caused those issues, see the numerous threads in the forum.

I would suspect network problems or issues with JOSM isn’t really designed to be used offline and downloads a substantial amount of configuration data on startup.

There is a command line option that enables offline use Help/CommandLineOptions – JOSM I would suggest seeing if the behaviour improves with that set.

Regarding the JOSM download site, what you say may be true but I’ve used JOSM thousands of times and it always loads in a minute or less. I’m talking about many minutes here.

Also, vectorial8192’s post may be tangential but I think off-topic is a bit harsh. We are looking for answers to some bizarre and even unprecedented behavior.

You say there are “numerous threads in the forum.” Fine, but which forum and what topics? I don’t know where to look for solutions to this very vexing problem. The Help pages on the German JOSM site that mention Java issues are mostly years old. Where can I learn about the status of the Java version dilemma?

I do not believe myself to be off-topic.

From my understanding, OP made 2 points:

  • slow download of JOSM and related configs (I am uninterested on this)
  • slow download of actual OSM map data (I am very interested in this)

Then, I share my recent experience of unresponsive iD editor behavior, which seemingly is also about the slow download of OSM data.

Again, given how the iD editor is quite different from JOSM, I am already stating my post as a tangent.

Is a quote from you own initial posting. That simply points to network problems or the JOSM server being slow, or, very maybe, lack of available memory for the JVM. None of this is unprecedented, and no I wasn’t responding to you when I pointed out to @vectorial8192 that there are numerous threads on the vandalism from last week.

And I’m sorry, but if you would rather argue, instead of testing what I suggested to you to narrow down the possible causes of your issues, then you are on your own.

A lot goes glacial on my W10 desktop when my mobile is also hooked to the same same wifi hub… first thing I do when starting mapping… switch mobile to mobile data.

When JOSM freezes I can’t launch Task Manager to kill it or it takes the time to brew a cupper, so I keep is running and minimized to system tray given the Taskbar remains functional. Barely uses cycles in that minimized state. Also the web browser goes glacial when JOSM freezes or goes catatonic. Considering OpenWebStart pulls it’s own Java (v21 now), can only suspect there’s Java races going on on the system (there’s 3 java installs discovered during a discussion with the JOSM developers).

This doesn’t sound good. I haven’t encountered it on my system.

Can I get a Status Report from everyone encountering issues, and if someone is particularly computer savvy, output from a profiler (async-profiler or Java Flight Recorder) would also be helpful.

Hopefully I can look at the status report and see a common plugin that might be causing problems.


When I said unprecedented earlier, I meant in my own usage. I’ve been running JOSM almost every day for 12 years and have never, ever seen it behave like this. I have about 40% of system memory available in my system (~ 7GB) and measured download rates of about 400 Mb/sec (tested). I just tried to start it again and it’s been hanging now for 7 minutes and counting. It’s locked up totally.

To summarize:
JOSM hangs repeatedly when attempting to open a new layer on my system.
Once it loads, if it loads at all, downloads of OSM data are very slow.
Downloading executables from takes hours instead of seconds.

I am a very active mapper. Pardon me for being frustrated that I cannot use JOSM at all.

@vorpalblade-kaart I can provide some basic info via screenshots below.

@SimonPoole I can independently reproduce “JOSM hangs on loading configuration” with a fresh install; I happened to need to install JOSM on a new PC today. This is actually very much unprecedented so you really should recheck the status somehow. Like @AlaskaDave I am also trying to understand what went wrong and get help, because I have very similar symptoms but on something else. Please see my elaboration below.

Version 18822 obtained via Windows MS Store, hanging on somewhere after “initializing presets”…

…because OpenStreetMap API is apparently unreachable.

Thus, this does not seem like a JOSM problem, but an OSM problem itslf.

But the thing is that you had at least similar behaviour -before- the upgrade and that was what led you to upgrade in the 1st place.

So before going on a wild goose chase, I would suggest eliminating that it is one of the non-JOSM causes.aka downloads specifically from, firewall/anti-virus settings, IPv4 vs IPv6 and so on.

1 Like

On another tangent, why would unafiiliated websites somehow say OSM is down? For example I found this:

As of writing it says OSM is down. But, it says Google is fine:

Another question would be, why some external websites say OSM is down quite consistently (I tested this for a few hours now) but the official OSM status page does not have anything outstanding?

The reason I tried upgrading, and then trying to download an earlier version, and then upgrading Java, is because of the problems I was suddenly having with the setup I’d been using without a hitch for months. Nothing on my system has changed. No firewall problems, router problems, etc. I’ve used JOSM while watching YouTube videos and with several cell phones on my wifi network in the past with no issues.

This mystery baffles me and frustrates me. I’ve checked everything I can check. Now I guess I’ll just wait and see what develops.

What official OSM status page?

Was inaccurate when I wrote it, but I was referring to this which is in turn mentioned in Platform Status - OpenStreetMap Wiki

All green across the board, and yet I am struggling to load e.g. the iD editor.

Therefore, something must be happening.

Hopefully this is not because of some CDN problems, like e.g. some maintenance task was happeneing and I happened to request the stale copy of something.

I’m happy to report that my setup is working properly this morning. JOSM loads promptly and OSM data downloads quickly too.

I’m glad that whatever caused the issues we were talking about seems to be gone. I checked the iD Editor and it seems to be working also.

Indeed, I am seeing that the iD editor is now loading reasonably well.