JOSM edit line disappearing with Mapnik (true) [SOLVED]

I am having a problem viewing the lines as I enter new ways.
Under View, Map Paint Styles, I have JOSM Internal Style and Mapnik (true) selected.
When I draw a new way, firstly I see a little red dot when I click on the map and then a red line extends from this dot as I move the mouse around, but when I click on the map to put my next point on, the red line disappears and only the new red dot appears, so that I am unable to see where I’ve laid the way…but the line appears again when I move the mose but only draws from the previous point.
If I uncheck the Mapnik (true) selection and just have the JOSM Internal Style selected I can see the track again. As soon as I check the Mapnik (true) option the new track disappears but once I have added a property such as Highway=residential, all the way appears as expected. If I select the last point in the way (with the Highway=residential tag added) and extend it, it is also viewable.
Only when adding a new way and having Mapnik (true) selected is this problem apparent.
There is another problem in that I cannot click the Wireframe View on and off from the top menu, but I can do it using the keyboard and I can also do it ok by loading the Map Paint Styles box via the Window menu and check and uncheck the wireframe view from the box at the right of screen? The mouse selection at the View menu used to work fine until recently.
I thought it may be to do with the colours under preferences so I reset those to no avail.
From memory now, I think I line normally stays red as you draw around marking a way and even after double clicking on the last node to finish it used to remain red and visible.
It is as if the hidden part is slipping below the Mapnik layer as I draw the way.

I also have ‘P2 Potlach 2’ loaded and if I check this and uncheck Mapnik (true) everything works fine.
I have only recently added the Mapnik true option but can’t remember now if I have used it previously because I haven’t done an edit for a while due to a fall off the cycle (now ok) and I have also just done the latest JOSM upgrade too so where the problem lies is a bit of a mystery.

Although it is possible to edit satisfactorily without the Mapnik layer selected, and use the Potlach version, I would prefer to fix it if it is easily done. (It may be the normal expected behaviour too I suppose)

I have just upgraded to 6238 but JOSM still tells me this…

“You should update!
JOSM soon will no longer support this version of Java, you should update to version 7 or better!”

My iMac 10.6.8 is unable to upgrade to Java 7 due to Mac not supporting it but the 6238 is based in Java 6 anyway.

I have this setup…
identification: JOSM/1.5 (6238 en_AU) iMac OS X 10.6.8
Memory Usage: 114 MB / 507 MB (11 MB allocated, but free)
Java version: 1.6.0_51, Apple Inc., Java HotSpot™ 64-Bit Server VM

Thanks, Nev

I would guess since Mapnik’s standard style does not render ways without attributes, it also does not render those ways in JOSM either. And since a new way has no attributes until you add some highway=* or the like, it is not drawn.

Your guess is correct. The Mappaint-Style “Mapnik (true)” is not meant for editing, but to see how it would look on the

Thanks guys
Best option for me is to edit using ‘JOSM Internal Style’ and ‘P2 Potlach 2’ selected for the usual editing and use Mapnik (true) selected to check how the final product will look on if necessary.