JOSM crashing issues - MacOS

Does anyone have any tips or pointers to tips for troubleshooting JOSM crashing issues?

I’m running JOSM on MacOS Ventura 13.3 & have tried using OpenJDK 17 & 20, starting a direct download with % java -Xmx8G -jar ~/josm-tested.jar

It hangs every time on “Rendering data set…” after downloading data.

Thanks in advance for any leads / help!

Lets start from obvious: have you tried to update JOSM, Java, OS etc?

Have you tried starting JOSM from command line so logs are appearing?

Have you tried downloading smaller area? Maybe some specific data hangs it?

Is problem persisting on disabling plugins?

You can also use Help | Report bug in JOSM itself if obvious things failed and it looks like JOSM bug.

1 Like

I’ve just tried to run ~/josm-tested.jar the same as you and did not have any issue with it.

Tested on Ventura 13.3.1 against this JVM

➜ java -version                               
openjdk version "20" 2023-03-21
OpenJDK Runtime Environment Temurin-20+36 (build 20+36)
OpenJDK 64-Bit Server VM Temurin-20+36 (build 20+36, mixed mode)
JOSM state report
Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2023-03-30 16:51:36 +0200 (Thu, 30 Mar 2023)
Build-Date:2023-03-31 01:30:56

Identification: JOSM/1.5 (18700 uk) Mac OS X 13.3.1
OS Build number: macOS 13.3.1 (22E261)
Memory Usage: 900 MB / 8192 MB (309 MB allocated, but free)
Java version: 20+36, Eclipse Adoptium, OpenJDK 64-Bit Server VM
Look and Feel:
Screen: Display 1 1512×982 (scaling 2.00×2.00) Display 2 1920×1080 (scaling 2.00×2.00)
Maximum Screen Size: 1920×1080
Best cursor sizes: 16×16→16×16, 32×32→32×32
System property file.encoding: UTF-8
System property sun.jnu.encoding: UTF-8
Locale info: uk_UA
Numbers with default locale: 1234567890 -> 1234567890
Dataset consistency test: No problems found

If you try that on a small data set only, does it still hang? When it does hang, what is your computer doing? Is something using CPU, disk io etc.?

Hi Mateusz - thanks for checking in here.

Yes - JOSM, Java, OS are all up to date.

Great suggestion, but different area, smaller data sets all hang.
2 different approaches on this:

  • Overpass queries - these all hang (5MB one area, 16MB a non-overlapping different area)
  • Individual area from standard API server - these work, but after a few small areas, performance drags to a stop.

All plugins are disabled & the problem persists.

I’d file a bug if I thought it was a bug… I think there must be something wrong on my machine, but I cannot figure out what. I have JOSM running well (but a bit slowly) on a Linux VM on this same machine…

1 Like

But… Mateusz & Andygol (Thank you, too!) both got me thinking, so I started JOSM with the reset-preferences option and everything seems to be working.

Now I have grounds for a bug report, but I’ll need to figure out what setting / customization / filter / whatever might have been causing a problem.

Luckily, I had downloaded a State Report (h/t Andygol!) before resetting things, so I’ll have something to work with.

1 Like

Hi Andy - Thanks for responding! In addition to other comments above, I had closed all unnecessary apps & this was still happening.

Sounds like a problem with some active mappaint style.

Skyper - I think you’re onto what was going on. Not sure which one might be the culprit, but hope to isolate & report back.

Too bad, you did not backup your preferences in advance to resetting them. On linux, I usually just use a different josm.home for debugging like:

 JAVA_OPTS="-Djosm.home=/tmp/josm" josm-latest

Some plugins also deliver a mappaint style and some create special layers which could fail to render, too.