JOSM 15322 can't import specific shape file

Hi from South Africa ,I hope someone can be of assistance as I’m very noobish and still learning(steep learning curve):stuck_out_tongue:

Background: Using latest JOSM and Java
I’ve successfully imported my countries river shapefile received from Department of Water and farm boundaries from Surveyor General which I exported to .osm format which I then convert to .obf(I use “osm to obf creator”) for use in the Android OsmAnd app.

I currently received the countries current police station boundaries(i need only boundary lines) also in shapefile format but get a error when trying to open file(the “opendata” plugin is loaded). The error displayed without quotes:“”

I can however open the specific file in app QGIS Desktop 3.8.3 but haven’t a clue as to export it so I can use it in Josm

The specific file

I would greatly appreciate help in this matter as to what is the problem and how to fix or help me rectify file so JOSM can open it or get into .obf format

I also was able to open in QGIS 3.6 but on saving as shapefile from QGIS and opening in JOSM also resulted in the same error.
I was able to save from QGIS as GeoJSON and that opened ok in JOSM.
On opening your shapefile in QGIS, I used the following steps…
Select>Select features> drag over dataset to select all displayed.
Edit>Copy features
Edit>Past features As>New Vector Layer
Choose Format GeoJSON
File name Police_bounds > select the … and choose a folder to save in like Downloads
CRS EPSG:4326 WGS 84
all other default fields are probably fine, then OK at the bottom
and you should be able to open the GeoJSON file fine in JOSM.
I opened a new layer in JOSM and download OSM data around Hout Bay marina and a bit of the coast around Table Mountain National Park and the GeoJson file data seemed to align ok.

Pleast ensure you have permission to use such data to update the OSM. You may need to get a explicit waiver from the data custodian to do that, depending on the type of open licence.
You local OSM talk mailing group should be able to assist with that.
Also follow the imports guidelines

Hi nevw,
Thanks for your reply and helping me solve this problem,never thought GeoJson format could resolve this. I wonder what was the difference between the other shape files I successfully used and this specific one…You really helped me a whole lot and my gratitude is endless. It worked like a charm :smiley:

Yes,you’re 100% correct about getting permission first to update OSM;)
According to our laws I’m free to use for my own use,so I can use it with OsmAnd for myself, but I may not upload it to OSM due to copyright law(and Spatial Data Infrastructure Act, No. 54 of 2003)yet…If I get permission to do so in future I will upload it(my aim is to combine with all farm names and boundaries and water like rivers,streams and dams),but for now it’s for personal use. If I get all data compiled and working without map errors and alignment, the next step would be to get that waiver and upload it…the result would be that OSM will have more current data and volume than Garmin,because in the past it was only Garmin that had offroad data and topo’s, but its outdated since 2012

Currently I contribute by only adding and rectifying to OSM for my country, but will follow the guidelines as you posted(thanks for that) 'cause I would like the community and everyone first to inspect data when I get permission

Kind regards