internet explorer always jumps back to the same location after CTRL+F5

Since today I have noticed a strange behaviour of the IE8: The IE8 always jumps back to the same location after pressing CTRL+F5 (forced reloading of the tiles). The same happens, when I press “edit”. Not the current location is opened for editing but always the same location. (BTW:FF3.5 work like usual.)

Is somebody else experiencing the same?

Grettings! ALE!

What is the URL in the addres-bar at that moment? Have you set up any restrictions regardring cookies for

The URL was There are no cookie restrictions for OSM, in fact due to the problem I have defined an exception to allways allow cookies but the problem still exists.

I think that is normal behaviour. Click “Permalink” on lower right corner and then press Ctrl-F5 and your current location doesn’t change.

No, if there is no location information URL, OSM should take the last visible position from a cookie. This cookie should updated every time you move the map.

It is definitively not the normal behaviour. Because up till today it always worked. Somehow (since) today the cockie does not get updated in IE8.

I have now tried with a different computer and IE8 shows the same wrong behaviour. In FF3.5 it works. Something is wrong with Potlatch.

I’ve just set up a new PC where IE was never connected with After granted to store cookies I could reproduce the error. When I checkd IE-Cookies it turns out that no cookie was stored at all. So I guess there is a bug in the OSM-Homepage-Script. Could not check because seems to be down right now. :frowning:

I am having the same problem. I was in view mode looking at the map covering France two nights back and closed down there. Now that is where Potlatch opens and when I scroll back to home teritory, which is south east Queensland, Australia, if I click Permalink, or View the map reverts to France. Even when I have scrolled back to home teritory I can’t get in to Edit as even on full zoom I get a message that tells me that I muist zoom in to log on.

I have another computer that runs Firefox instead of IE8 and it is working fine but it had not been on for a couple of weeks as with OSM I only use it for setting up routable map downloads using Firefox.

I hope this contribution helps. Its most frustrating when you want to do some mapping and can’t.


That triggered my memory about another weird IE problem that popped up this week after Windows Update - another site had a problem and and IE8’s ‘objection’ was that there was no code defining a privacy policy. After doing some research based on the error messages, they added a wc3 folder to the root with some privacy definition code, and add a couple of lines to the html code.

The error in OpenStreetMap is a bit different, but I get a Javascript error on the line ‘node.addClassName(“disabled”);’ in ‘site.js’. I believe they have added strict mode for some aspect of web page processing. I don’t have time to track it down at the moment.

I have confirmed that the error above : ‘node.addClassName(“disabled”);’ in ‘site.js’ is the thing that prevents IE from updating the cookie location after zooming into the area of interest. So, even with cookies enabled, the cookie that sets the location next time is the cookie for the original location. Someone will need to update the OSM home page for the new IE incompatibility.

This has been fixed, thanks to TomH / MarcS! Future locations should now be saved when restarting IE.