Importing data very slow after first import

Hi all!

I’m following this HowTo
Yesterday I started the import of Germany’s data. After 58 minutes done. Wow!
Then I imported the shape files.

Today I started the import of Czech. After more than one hour it didn’t start processing the nodes, ways and relation…
I find this is very strange, since Czech is very little than Germany…

Could someone explain me the behaviour?

The PC I’m using to process these data has a Xeon E5-2680 v2 2.80GHz (20 cores) and 32GB RAM. The disk I’m using for Postgres is an SSD.

Thanks for your explanation

Is this a new database or do you try to add the Czech data to the existing data for Germany?

I’m trying to import the data for Czech in the same DB I already used for Germany. So using --append instead of --create.
Data for Germany are in the DB.

Other question: I see now that the import for Germany didn’t complete without error:

node cache: stored: 330157901(100.00%), storage efficiency: 50.23% (dense blocks: 1515, sparse nodes: 322447601), hit rate: 100.00%
Osm2pgsql failed due to ERROR: Connection to database failed: FATAL: die verbleibenden Verbindungen sind für Superuser auf Nicht-Replikationsverbindungen reserviert

So someone know what does the program mean and how to solve it?!?


You should have combined the files before the import e.g. with osmosis.

OK, can you say me how to do that (maybe an example or an HowTo)?

Then: what does the option “–append” mean, if not for this case?


–append is used for updates over the original file (diffs). They come with osc extension.

About merging files, here’s a good starting point:

OK, thank you very much!

I’ll try to merge the data