img Files inspector

I’m looking for a program which can display details like road-class and road-speed for
garmin img files.

I tried QLandkarteGT, but this only shows the garmin-type code like 0x06 for residental streets.


GPS Mapedit can do this,

That seems to be an interesting tool. But it has a lot of problems, at least on my Win7 64bit computer:
All roads are road class 0 (unpaved minor) with a speed limit of 5 km/h… It does not load a map of Germany (too big, despite 8GB of memory). Maps look different on screen than they do on the device (i.e. style file is not used by the program)…
I just sent a bug report to them.

I can not confirm this for the map I tested. (also win7-64)

A have a minor issue: For overlay-lines (several lines over another), I see only the top-one.


GPSmapedit is the standard editor for files compiled with cgpsmapper.

Class 0 roads are basically routable lines that have not been classified as anything more specific. They generate a warning when compiled with cgpsmapper, and are generally not used.

Is it possible that the IMG file you opened did not have roads classified?

After reading this thread I tested the tool with my own map. I see the same problem, all roads are classified as “0” with a speed limit of “0”. The map is generated with mkgmap and all roads have road_class and road_speed set. Routing works fine with mapsource and various GARMIN devices.

Between, I’m using wine on Linux.


The problem is that all levels of the map are represented in the IMG file. If you zoom in to about 30M (100 ft) and select a road that is type 0 at 300M you will find that it has a defined road type (in the sample I just tried it was type 0x4). The sample was generated using a Geofabrik of the western US compiled from the PBF with mkgmap.

Yes, if I zoom in further it works.


Exactly, I have to zoom in to a level of 150 meters.
By the way, for my user defined road types (e.g. [0x10e01 road_class=0 road_speed=1 resolution 20]), the tool says “unknown” and a “routing” tab is not displayed under “Properties”. Maybe I missed something when setting up my style file. Any hints?

Without seeing your map, I can’t be sure, but I suspect that your custom road type is something that mkgmap recognizes but cgpsmapper doesn’t. As I said above, this is the main editor used with the cgpsmapper compiler, and mkgmap and cgpsmapper do some things (like the map header) quite differently.

0x10e01 is not a routeable type, that’s why. Routable types are: 0x01 - 0x13, 0x16, 0x1a, 0x1b only