Imagery offset server moved? ("JOSM: HTTP Response code 301 (Moved Permanently)")

I’m using Debian’s JOSM 19096 with an old setup. Anyone else seeing 301 responses today when trying to get or store imagery offsets (e.g. Imagery → Get Imagery Offset…)?

Guessing there’s an infrastructure change afoot, and JOSM doesn’t seem to be able to handle the 301. If I knew what to change I would, but it’s not obvious which setting to prod.

In the Advanced Preferences of JOSM (check Expert Mode), find the iodb.server.url and change http to https

Hi guys, and sorry for that. I’ve enabled http back on the server, so no adjustments neccessary.

Been annoying me for days, and expecting it to fix itself. Nothing on the wiki page

Thankyou, TrickyFoxy for the solution.

I’m going to add a quick and ugly link to this post in wiki page. I’m going away for a couple of days and havent got time for proper editing.