iD not fully loading and effectively unusable [Resolved]

Edited to add that the problem has been resolved by 2.6.0, which appeared on 2018-01-22. Remainder of post left unchanged for archival purposes.

Edited to add this:

I’ve had a problem with iD which started 2017-11-16 and hasn’t resolved itself yet. Up until the 16th I had no problems with iD at all (I used it successfully on the 15th). Other funky web 2.0/AJAX/JSON sites, such as youtube, continue to function normally.

I initially mentioned the problem in the Q&A forum at, since I figured I’d quickly get many responses along the lines of “I also have this problem” or “Works fine for me” or “You’re an idiot.” No point troubling the devs if ordinary users could quickly tell me yay or nay. Continued silence (which I find unnervingly strange).

The problem is this. Most of iD loads fine. Objects (ways, buildings, etc) show up. Background shows up and can be changed between, for example, Bing and Digital Globe. In fact, all the controls at the right work. The map can be zoomed (with controls or scroll wheel). The map can be moved around and the appropriate tiles load. Search works. However… The spinny thing at top-right never stops spinning (I’ve left it for over 30 minutes). The point/line/area controls at the top cannot be selected. I cannot select an object to modify it. After 20 or 30 minutes an error bar appears near the bottom, white text on red, with a message along the lines of being unable to connect to the API.

This was on CentOS 6.8 (still in long-term support) and Firefox 52.4.0 (64-bit) and no recent upgrades to either. After a day without an answer on the Q&A forum I rigged up another computer with CentOS 7.3 and Firefox 52.4.0 (64-bit), and got the same result. Today, with still no answer on the Q&A forum I got hold of a laptop with Windows 10 (ugh) and some flavour of Edge (ugh) and got the same result. I did try Potlach and made a change successfully, so my user hasn’t been blocked from editing.

Oh, and it’s not my ISP’s DNS server screwing up, because the last time my ISP broke their DNS for half a day I switched to running a local copy of BIND for my DNS and never switched back.

So I figure one of the following is the problem:

  1. I’m an idiot. Often the case. In which case please tell me which particular idiotic mistake I’m making.

  2. Some change to iD borked it but nobody else has noticed or is complaining. Unlikely.

  3. My ISP, Hutchison 3G (aka “Three”) has a routeing problem that’s stopping me connecting to the API server.

  4. I’ve slipped into an alternate universe. In which case I need to know which one so I can add the appropriate universe=* tag to new objects I map.

At the moment the most plausible explanation (apart from number 1) is number 3. My ISP has a routeing issue or has blocked connections to the API server for some reason. If so, is there a diagnostic URL for the server that would return a meaningful response? Or the domain name or an IP address so I can traceroute it? I’d need to be able to tell Three exactly what the problem is to have even a faint chance of getting it fixed. Otherwise they’ll just suggest I reboot my phone, because that’s the only fix third-line helldesk people know of.


Same problem with iD and the thing spinning around

I guess it’s better to report bugs here: