How to show the transparent layer on JOSM?

How to show the layer of the transparent map with a transparent background?
When I add the transparent map ( just like the google annotation map---->
tms:{x}&y={y}&z={zoom}&s=Galileo )
into the map layers, I can see this transparent map of the google annotation and other maps at the same time.
But, the google annotation map isn’t transparent. Its background is the default white color.
What do I do to let the map transparent? It is because that I want to show the map just like this…
Although I can adjust the transparency of maps on JOSM to see this similar result, it is not convenient. Thanks.

In case you aren’t aware: You must not use the Google layers when contributing to OpenStreetMap:

Feel free to ask if you have this problem with another imagery layer.

I am sorry for asking this sensitive question. I know that some maps have their copyright. In fact, I don’t want to use the google map on JOSM.
I just take an example for explaining my question. The transparent map I really want to use is below. It is the boundary of my country(Taiwan) on the map.


Could anyone help me to let this map having a transparent background (not the default white color)?
If it can’t do it on JOSM 7643, can other versions do this? Or, I should take a suggestion to the JOSM designers?

JOSM does support transparency, but the image file that comes from the server must actually have transparent background. Try using PNG format instead of JPEG (along with option TRANSPARENT=TRUE):


Thank bastik. It is very successful to use your new wms code:


Now,I have the transparent boundary over other maps. I am very happy. Thank you again. :slight_smile: