How to get data off Garmin etrex in Linux

I got a Garmin etrex and a serial → USB connector off eBay a while ago to do some mapping in Crete.

I’m trying to find out how to get the data off the GPS using Linux and I’m somewhat stuck and googling is not helping ATM

Basically the device seems to connect as /dev/ttyUSB0 - I ran a ‘tail -f /var/log/messages’ and, although it shows a bundle of error messages to do with plasma, does say it’s connected as ttyUSB0 and launches gpsd.

I’ve tried running QLandkarte but it always comes up with an error trying to access /dev/tty0.

What I need now is some way of accessing the device and right now I don’t know where to go next so any info anyone can give me will be gratefully received.


gpsbabel is the way to go…

remember to kill/shutdown gpsd and similar programs first.

What I’m seeing at the moment

hwinfo --usb

05: USB 00.0: 0700 Serial controller
[Created at usb.122]
UDI: /org/freedesktop/Hal/devices/usb_device_67b_2303_noserial_if0_serial_usb_0
Unique ID: TVZz.yosUmW5iOW6
Parent ID: pBe4.kllrQr_lFX9
SysFS ID: /devices/pci0000:00/0000:00:02.0/usb2/2-9/2-9:1.0
SysFS BusID: 2-9:1.0
Hardware Class: unknown
Model: “Prolific PL2303 Serial Port”
Hotplug: USB
Vendor: usb 0x067b “Prolific Technology Inc.”
Device: usb 0x2303 “PL2303 Serial Port”
Revision: “3.00”
Driver: “pl2303”
Driver Modules: “pl2303”, “pl2303”
Device File: /dev/ttyUSB0
Device Number: char 188:0
Speed: 12 Mbps
Module Alias: “usb:v067Bp2303d0300dc00dsc00dp00icFFisc00ip00”
Driver Info #0:
Driver Status: pl2303 is active
Driver Activation Cmd: “modprobe pl2303”
Config Status: cfg=new, avail=yes, need=no, active=unknown
Attached to: #11 (Hub)

so it looks like it’s connected

l /dev/ttyUSB0
crw-rw---- 1 root uucp 188, 0 Apr 3 17:18 /dev/ttyUSB0

as root
gpsbabel -i garmin -f usb: -o gpx -F waypoints.gpx
Found no Garmin USB devices.

I tried killing off gpsd and running gpsbabel again as you suggested but with the same result.


The GPSbabel mailinglist is probably the best place to ask for more help.

sry :frowning:

If you are using a USB serial adapter, then the Garmin will be connected on /dev/ttyUSB0, not usb:. So try running gpsbabel with this.
gpsbabel -i garmin -f /dev/ttyUSB0 -o gpx -F waypoints.gpx

Beat me to it :wink:

I tried /dev/ttyUSB0 out of sheer curiosity - the web page says use usb: for all usb devices and lo and behold! it worked :slight_smile:

Now all I have to do is convince the thing to give me access to /dev/ttyUSB0 as a user rather than root.


Just add your user to the uucp group.