how do I get a mapsource OSM map?

What would be the recommended approach if I want an OSM map loaded in Mapsource?

eg I’m on a stop-over in South Korea and would like some sort of map (doesn’t need to be routable),
Note I will want to load other maps, so IMG format is not useful.

Is any existing map (eg teddy World map) for S. Korea (Seoul) available or do I need to build my own.

If I need to create my own which Wiki page should I follow ?
btw are these wiki pages updated with the new registry format for latest mapsource?


Download the area in xml format
Download mkgmap
Compile the area with mkgmap into a Garmin map
Create the registry key:

Windows Registry Editor Version 5.00

"LOC"="C:\\Program Files\\OpenStreetMap Garmin maps\\NL-NORMAL"
"BMAP"="C:\\Program Files\\OpenStreetMap Garmin maps\\NL-NORMAL\\11000000.img"
"TDB"="C:\\Program Files\\OpenStreetMap Garmin maps\\NL-NORMAL\\11000000.tdb"

When providing no parameters to change family and series id’s. You need to use the correct path and image numbers as well (default: 63240000)

I see no other option as noone else makes a map installer for South Korea.

thanks for the good summary, can I export XML from OSM map page?
I notice the Export XML option is disabled, do export from another website or tool?

edit will the JOSM OSM/XML file be suitable?

  1. java -jar mkgmap.jar --route map.osm
    this just creates a “63240001.img”
    where are the other two files created from? (img and tdb)

Export is probably disabled as the db is updated. But you can use the OSMXAPI server for that too.

I think so, yes.

Add the parameter --gmapsupp to the Mkgmap commandline.

I added that parameter but still no 63240001.tdb file but it did create a gmapsupp.img file now.

ahh I see a --tdbfile option so it should be:

java -jar mkgmap.jar --route --tdbfile westoncreek.osm
this creates 3 files


which I created a reg file

Windows Registry Editor Version 5.00


and when I ran mapsource it borked about this product=42

PS should I recommend that the mkmap create the map.reg file with the above files coded

Ah, yes ofcourse, my bad.

Ok, so you’re probably using one of the latest MapSource versions which are more picky about map product numbers and so. I was under the assumption that 42 was the default, but maybe that has changed. You can force the number by specifying the product number by adding --product-id=42 to the commandline.

You can also change the product-id of a existing map with the TDBChanger application.

thanks for your help so far…
good news is with this
java -jar mkgmap.jar --route --tdbfile --product-id=42 -n wcreek westoncreek.osm

I don’t get any erorrs,

bad news map is ignored by Mapsource (ie not show in list)

now here is the reg that MapSetToolKit generates when I import map.

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Garmin\Mapsource\Families\South Korea]
"IDX"="C:\\Garmin\\build\\South Korea.mdx"
"MDR"="C:\\Garmin\\build\\South Korea_mdr.img"

[HKEY_LOCAL_MACHINE\SOFTWARE\Garmin\Mapsource\Families\South Korea\1]
"BMAP"="C:\\Garmin\\build\\South Korea.img"
"TDB"="C:\\Garmin\\build\\South Korea.tdb"