high cpu-load with potlatch normal?

I may be having a problem with flash or firefox or whatever, but every time I try editing openstreetmap online with potlatch the cpu-load on my machine rises. Ok, I didn’t by the hardware yesterday; it’s an AMD Athlon Processor 3200 with 1gb RAM. But shouldn’t that be enough ??
Even moving the mouse in potlatch’s edit mode seems to be very hard work for my machine. Other flashcontent runs without trouble.
Any idea?

You are using Linux? It’s a problem I have with potlatch on Linux as well.

I’m working on a bunch of performance improvements for 0.10c. One thing you can try, though, is disabling the custom pointers - that usually improves performance. (Use the little ‘tick’ at the bottom left to get the options window.)

@ emj - yes I’m using Linux (Ubuntu)
@ Richard - Thanks a lot. There are still high cpu-loads, but it’s a lot better this way. I should have tried it before.

Doesn’t help me much though… Still slow…

I had all sorts of problems with Potlatch under FF in Windows - so much so that I have switched entirely to JOSM.

It would generally be fine for a while (5-10 mins) and then slow to a crawl. A minute or so later it would freeze the machine for 30 seconds or so, free it for 30, freeze it for 30 etc.


There were some performance issues crept in with 0.10. I’m working on them (well, in the spare moments I get in between replying to “why is it running slowly”…).