Help! JOSM Max Nodes Exceeded


I lovingly drew a laarge lake, a place where I love to drive.

However, after the 45 minute excercise, JOSM says I have 2777 nodes, when I am allowed only 2000.
What do I do?

Search yielded results half in german. Couldnt understand. I really want to upload this one. Please help. The lake is very large with a road running its entire circumference, hence accuracy is required.

Split the line into two or more pieces, each having less than 2000 nodes. Next, create a multipolygon with all those lines.

How do I create a multipolygon?
I split and then tried creating a multiplygon and it says ‘Each Way Must Connect 2 Nodes’ or something like that.

The last node in way A must be the first node in B (and so on), forming a complete ring. Otherwise, the “create multipolygon” tool will pop up that error message.

Can you check whether this is the case with your ways?

I cant figure that out! I created a complete vector drawing around the lake and joined the last node with the first.

If you would like us to look at your changes, you could save the edits to an .osm file and upload it somewhere for us to look at. You can also [mail it to me directly](mail it to me directly) if you don’t know a good place to upload such a file.

I have now received the file, so I could look at the situation in JOSM myself.

At least in the file you sent me, the way is not closed (see left image). If I close the way (as shown on the right) and split it into multiple ways below the 2000 node limit, the “create multipolygon” tool works as expected.

Don’t forget to add the appropriate tag, too! Once I did, JOSM’s validator complained about the unclosed way and was able to zoom to the problem. This helped me a lot to find it.

I couldntt figure out how the validation helped you zoom in. Would you be kind enough to upload this? I will add the tags via Potlach.

I added a tag (natural=water) and opened the Validator dialog. Then I started a validation using the “Validation” button. Among the reported warnings there was “area style way is not closed”. By opening the folder for that error category, I saw the single warning from that category, right-clicked on it, and selected “zoom to problem”.

Do you want me to upload it to the OSM database? It seems that it would help if you tried yourself so you can learn how it works.

Thanks for the detailed explanation. Will try it today. Not used to right-clicking, as I use a Mac, but I think this should work.

I had used the natural=water and the name= tags. Guess when I tried to undo, I must have lost them. Thanks again.

I tried, but have not been able to get in in between my fleeting schedule. Would it be too mcuh if you sent me a corrected polygonised file and I upload it?

(when I tried to ‘create plygon’, it still says 2 nodes should be connected or such. But the validator is not giving any unjoined way error. Splitting the way/drawing is creating more problems. Wish I had worked on Potlatch :frowning:

Ok I guess I will abandon this attempt for the time being. I havent been able to figure out how to split the way and create a multipolygon without creating a zillion errors. I also tried exporting a gpx from JOSM and uploading vioa Potlatchm but that too showed an error (perhaps lack of time stamps).

I guess, at least for me, I will try to create complex shapes in Potlatch only.