Has anything changed in processing maps since March?

I use the maps the easy way: chose area, download map, store the gmappsupp.img on my Garmin etrex vista hcx.

My previous last download is from March,21, 2011. With this map I can see locations (German: Orte) via their name displayed even when outzoomed (eg 8km). The last download is from yesterday and now there are no location names, until I zoom in so close, that my etrex shows even pizzerias and drug-stores (120m).

With the previous downloaded map I could use “find” with locations and streets, now nothing … But now every highway name is shown (outzoomed) from primary and secondary.


I also do something similar: select the tiles I need, download them as *.img files and then use img2gps (free software) to upload them to my Garmin Etrex Vista HCx.

What’s happening with maps since May (the last one that still worked correctly I downloaded from 30 April 2011) is that I can’t do a search for street names. No matter what I put in, my GPS tells me “Not Found”. This was not the case with earlier maps on this unit. The earlier maps also worked for the Nüvi 205. I’ll have to check whether the newer maps since May still allow a street search on that particular unit.

Earlier maps that I loaded onto a friend’s Garmin GPSMAP62 or a larger Nüvi also didn’t find any street addresses. I’ll also have to check whether the newer maps now work on those devices.

I can search for POIs, though. The restaurants or hospitals, etc. do come up in a search. It seems (as far as I’m aware at the moment) to be just the street name searches. The street names are on the map if one moves the cursor to the streets. These names can be switched off on my unit by selecting “declutter on” in the menu. Then only major route names or numbers are shown on the map, and no POIs.

The conclusion is that somehow street searches are now being done differently and the Etrex Vista HCx can’t work with the new format. Is this correct? Is there a way around it? Has it got to do with how I load the maps? I’ll try download a map from http://garmin.openstreetmap.nl/ by allowing them to compile it and see whether that makes a difference. In particular, I’m using the tiles for South Africa.

Anybody else having a similar problem?

Yes, a lot has changed in the period between now and March, I don’t know where to begin and don’t keep a list…

But I have recently downloaded and installed a countrymap on my GPS and guess what: I can search for streetnames just fine. But I must add, there are quite a few quirks, some I notice without much trying:

  • Some streets are listed under a different village (e.g. Apeldoorn and Ugchelen are two villages very lose together and some streets are listed under Ugchelen while they are in the middle of Apeldoorn but the street next to it is properly listed under Apeldoorn.)
  • Some streets are not found at all.

But this doesn’t nearly sound like the problems you’re having. Have you tried to upload the image without using img2gps?

BTW, a lot of effort is put into Mkgmap to improve the address searching. There is a special development branch that I expect to be merged with the trunk of the source code soon. I always try to use one of the latest trunk versions so I hope there will be an good improvement in address search soon. No promises ofcourse as this is out of my hands.

Thanks for your reply, Lambertus.

I’ve been trying various combinations to see whether I can get things to work. As it turns out, actually the last working map (in terms of searching for street names) is from 7 March 2011, not April, as I had thought. I think I just didn’t do any searching with later maps and only noticed now that the search function doesn’t work anymore.

I tried downloading the gmapsupp.img from your site, then loading it using Windows Explorer. That didn’t work for searching for street names. I tried using the one that is loaded with MapSource. Searching also doesn’t work. I tried a map from Germany and used img2gps. Also no search function working.

However, on all of these new maps I am still able to autoroute if I just select where I want to go as a destination using the cursor, or going to a POI. So that part of the maps works properly, but the search just comes up with “None found”.

I think you guys are doing a fantastic job with the maps, and I hope the Mkgmap address search project bears fruit when you merge it with the main software. In the meantime I’ll stick to adding more info to the maps via OSM, but will probably keep the older map in my GPS for now, in case I need to search.


Very strange, as there is quite a difference between no search functionality and partially functional search. I’m sure the searching works for partially (while keeping in mind the issues above).

If you enter a default housenumber, like ‘1’ and then proceed to type a streetname, does de GPS then at least show some streetnames at first (e.g. after entering the first character)? It definitely should do that.

Thanks :slight_smile:

Hi Lambertus

I’ve checked all the possibilities. On the new maps:

I can search for POIs. I’ll get a list and can select what I need, whether hospitals, fuel, food, etc. The unit will also autoroute correctly.

I can search for cities. The list that is generated first is one that has the closest cities to my current location, and these are followed either by the 3-letter code ZAF, or the words “Cape Town”. When searching for a city by name, what’s different now is that the South African cities have a province after the city name, e.g., Gauteng, Western Cape or Kwazulu Natal. In the past they had a 3-letter code of ABC (presumably a country code; Great Britain was GBR and Germany was DEU, Netherlands was NLD). So, if I search for “Worcester”, I’ll get two hits. One is “Worcester, Western Cape” (that’s a town close to Cape Town), and the other is “Worcester, GBR” which is a town in the United Kingdom. Perhaps this is what’s causing the problem, and is related to how the data are entered into OSM?

I can’t search for street names or intersections. When searching for street names, my screen has three fields to enter data. The first is Street number. I always put in a “1” because our mapping is not yet at the stage where we have entered many street numbers on OSM. Then I would click to enter a Street name. At this point, on the old maps, my GPS would start an alphabetical list immediately, and would refine it until it converged to the right name as I added more letters. On the new maps the space where the list would normally appear remains “none found”. No names at all come up.

Searching for intersections also has three fields: Street 1, Street 1 and City. On the old map, as soon as I clicked to enter the first street, the list would be populated and would then converge as I added more letters to the name. Same would happen with the second name. With the new maps, both names return “none found”. No names at all come up.

On both those searches (street name or intersection), on the old maps, clicking on City name would bring up an alphabetical list of all cities in South Africa (perhaps only those on the specific map tiles that were loaded – I have not checked whether it was every city in South Africa). I would have to scroll to the correct city. If I tried to spell the city name, then I would also get a “none found”, so I generally never bothered to enter a city name.

Besides, I found that if I wanted to search for a street name on another tile, i.e., a tile that was loaded but was not the tile my current position was in, then I would have to move the cursor to that tile on the map first (change reference point), and then do the search. So if I wanted to search for a street in Johannesburg, which is on a different tile to the one for Cape Town, then a search would not find the street I was looking for unless I first zoomed out, found the correct tile on the map and placed my cursor in that tile.

I’m not sure if any of that information helps in making a diagnosis. On the weekend I’ll try load the new maps on a Nüvi 205. That unit used to do a search on the old maps. It didn’t ask for a city name first like some of the other GPS models do.

Thanks for the responses. I hope that there is a simple solution somewhere, and that this information can help towards making the search function on all GPSs work in future maps.


Just the feedback from trying out the newer maps on a Nüvi 205 over the weekend. Unfortunately, no luck there, either. It also doesn’t find any (matching) streets when doing a street search, and comes up with “none found”.


Just tried the latest map set and searching street names doesn’t work in Mapsource, on the 60CSx and the Zumo 660. In MS at least it displays street names while I type them in, but when I select one and hit Find it comes up empty.


It’s really weird. I open MS, goto address search. Type 1 for number then ‘Helemon’, click on ‘Helemon street’, then ‘select street’ and hit ‘Find’. The following appears:

Seems to work just fine.

I can confirm that the map I recently downloaded (I think it was 9 June 2011) DOES work for searching for streets in MapSource, as shown by Lambertus above. However, my etrex Vista can’t find any street names when I do a search.

I’ve just downloaded the latest map as a tile and the situation on the GPS remains – no street search working.

Since I did not download the exe file of the map and load it into MS (I downloaded only the tile and uploaded that to my GPS with img2gps) I can’t comment on whether this latest map works for address searches in MS.


You have to create img with Mapsource to get address search. It won’t work any other way. mkgmap creates search index for Mapsource, and there is no other 3-rd party program, which can convert it to format used in GPS.

Here is what happens sometimes in MS:

As you can see, it lets me select from a list of streets, but then when I hit the Find button it comes up empty.

For some streets it works, for some it doesn’t. E.g. a search for Stromberger Strasse works. At first I thought that it had to do with searching across tile boundaries, as NZOGPS had problems with that, but it’s not that.

now, that my observation is confirmed, back to my question: what has changed?


Like I said earlier: a whole lot has changed. I haven’t kept a detailed list.

You say you cannot find any street? This is different from my experience and what Beddhist reports: “For some streets it works, for some it doesn’t.”

I’ll see if I can borrow an Etrex Vista in an attempt to reproduce. Please tell me how you put the map on the gps. Which file did you download (e.g. the mapsource installer or the gmapsupp), how you uploaded the map to the gps (e.g. using MapSource, Sendmap or just copy/paste).

I go to the world-map, chose the right area, fill in my mail-adress, send and wait. Within the second following mail I click onto the link, within the webpage I click the gmapsupp.zip and save it. Then unzip, copy, insert my memorycard, go into the folder “Garmin”, insert, ready.


Thanks, I’ll try the same this evening.

I’ve been meaning to say thank you, Lambertus, for fixing the street search issue. The map from 17 July worked on my Etrex Vista. And it was possible to download the tile and upload it with Img2gps. I did not have to use Mapsource. The search function is preserved. Good work, whatever you did.

However, the latest maps I downloaded today (map from 5 August) again don’t list ANY streets when I do a search on my Etrex. Something has reverted again, it would seem.

I have found a temporary “fix” in the meantime: I load the map from 17 July which works, together with the new map. The search function for street names appears to be looking at that map, even if I switch off its visibility on the GPS unit. The only downside is that any newer streets and their names which were not yet drawn on that map will not come up in the search.

Thanks for your ongoing work in providing us with free routeable maps of the world.

Stefan, thank the Mkgmap community who are doing their best to understand and reverse-engineer the Garmin map format. A really smart bunch.

The change between 17 July and 5 August is probably an upgrade to the latest Mkgmap version (r2008).

Would it be possible for you to do some research into the latest version of Mkgmap that is still working for you? I really don’t have the time available right now (nor the coming weeks). I’m fully immersed in some structural changes to the website and trying to provide feedback to Ligfietser and Beddhist which, I shamefully must admit, is really lacking.

Were you guys ever able to find a person to do the research? I could look in to it potentially if there were any incentives. I have been studying android application development and its relation to IT services quite a bit lately. I would really like to help improve the mobile apps for open street map while I wait to hear back from the IT staffing people about my latest job hunt. Please let me know if there is any way that I could be of assistance whether it be IT work or development stuff. Thanks guys!