Generic Routable (new style) map with Basecamp 4.7.1

I installed the newly released Basecamp 4.7.1 on a brand new Win 10 installation followed by the OSM Free maps for Garmin Generic Routable (new style) for Texas. Basecamp opened for a few minutes then spun off an error message and closed. Now it will only give the error and not open at all.

I have uninstalled and reinstalled BaseCamp and deleted the maps from the drive, with no change. I also reinstalled 4.7.0 and got the same error.

I had this map in Win 7 with the prior version of Basecamp with no problem but am migrating to Win 10.

Any ideas on how to recover the use of BaseCamp? Has anyone else had a problem with 4.7.1? Is there an uninstall routine for the OSM routable maps?


I have tried installing Basecam 4.7.0 and 4.6.2 Both give the same error message, tell me to upgrade then stop. So going back doesn’t solve the problem.

You need to remove the registry entry for this map of Texas
Use regedit and search for the map’s name the remove its entry
More than likely it will be in Mapsource//Families

Failing that,restore your pc to an earlier version

A pain !

I did a manual registry edit and got Basecamp back running. I think there is some other problem with the computer as QGIS is hanging opening some projects and I have also had 2 BSDs today. All using a brand new SSD and OS. It may be time for new computer.

But while we’re on the subject, and not intending to hijack this thread in any way, is Basecamp 4.7.1 otherwise okay to install? I have been postponing all updates until I hear that they’re good to go.



I’ve heard that they have fixed Mapinstall, see not tried it yet.

Thanks ligfietser,

I seem to remember posts in this forum about a recent Basecamp release that had some routing issues and that was the reason I asked about this release. I never experienced any problems with the built-in Mapinstall function. Maybe I was just lucky.

I’ll go ahead and install it unless I hear something negative.

As far as I know routing issues are not related with a typical release and the issues with Mapinstall are only related if you use the installed maps with windows registry (installed maps with the so called gmap versions are not affected).

Thanks again.

I use only my own maps compiled with mkgmap.

I had not heard of that program and will look into it. I use a JaVaWa IMGfromGPX, which is no longer in development so it is good to have an alternative. I obviously need to spend more time hanging with OSM people to keep up.