garmin mapinstall - "data was not sucessfully sent" OSM only

first off, I use basecamp to create routes, waypoints and tracks (breadcrumbs) and back-up my dakota 10.
In the past I’ve used as a source, but after I received this error I tried

nothing OSM seems to work, garmin topo and city navigator works flawlessly… but I use my garmin exclusively with openstreet
because there are often hiking trails available. I have tried re-installing the maps, garmin software but nothing is working.

has anyone else seen this problem or, better yet, have any ideas how to fix this?

To handle tracks and maps on a Garmin Dakota you don’t need any special software like Basecamp; The GPS device is a simple USB mass storage (like a USB-Stick) for your computer, on which you can copy, delete and move files on. A map (*.img) you can simply copy on it, also routes, tracks and waypoints (as GPX files). Are you shure you don’t scratch any of the limits of your Dakota 10? Afaik 850 MB memory (and no SD card), amount of trackpoints etc? Can you copy a file (f.e. a track as GPX file) on it via USB and without Basecamp?

I know its a simple storage device… and its only using 1/2 the memory at any given time.

(edit:) perhaps i wasn’t clear enough. its only the map installer that’s giving me an issue, and only when I try to transfer an openstreet map.
are you saying the only solution is to download two maps; one for basecamp, and one for my garmin?

Beside the fact that I want open source software on my computer: Without Windows or Mac I’m unable to say anything about Basecamp (I’m using QLandkarte instead). But I expect that you don’t need separate maps.

there’s some really good open source software available but sometimes it just isn’t intuitive enough, etc… I tried qlandkarte at one point, I still prefer basecamp even if it has an occasional bug or two.

I hope someone comes across this thread can give help me find a solution. I assume this has come up before or will come up again.

You can check your device for errors (maps installed the wrong way for instance) with Javawa Device Manager:

thank you. it looks like an easy way to backup my garmin

on the plus side. it didn’t find any corrupted files… but I still don’t have an explanation.

You didnt describe your problem other than it just dont work.

simply put; when i use the garmin installer on openstreetmap maps that I’ve installed to basecamp I get an error msg, “data was not succesfully sent”… Garmin maps work without any issue… Since posting I’ve tried installation to usb stick, and a different openstreetmap source and get the same error. I’m sorry, there’s no other msgs, error codes I can provide.

Maybe you could try Mapsource instead of Basecamp

same problem