Garmin Etrex 30: in witch map do I have to put the osm .img?

Dear all,

I have downloaded the .img map from OSM, but can’t seem to find the right directory in the Garmin to put in in. Have tried severall: doesn’t work. I have a new type Etrex 30, just got it yesterday.

Thanks, Fred

Have a look at and choose the sub page for etrex series … maybe there are some hints about it.

The gmapsupp.img should be placed in the directory named ‘Garmin’. If this directory does not exist then create it.

Dear people,

First thanks for the help. BaseCampe doesn’t work on my computer though I have the right update Windows XP. I have put the .img in the Garmin map, but if I select the map, the Garmin can’t seem to find it. Also the standard card given another extentions .org. Doesn’t work. Have asked the supplier to send the Garmin back, it simple doesn’t work. Have asked the supplier to put a Garmin map on it, but he won’t do that. So I can’t buy a functioning Garmin anywere. Seems to me the same if you buy a new car without motor, and you can but different motors, but you will have to put it in yourself. You can’t buy a working Garmin. Actually very strange.

Best regards, Fred

It won’t work if you place files on the GPS that have names like: 63241586.img. If the name contains numbers like this then the GPS won’t recognise them because the .img files has a different format then the gmapsupp.img.

So, if you want to put a map on the GPS, download the gmapsupp.img version, unpack it (if the filename is and put it in the ‘Garmin’ directory on the GPS. That should work fine, anything else won’t work.

Dear Sir,

First thanks for the reply. I’ve done it, but it still doesn’t work:

(Have now also the other remaining .img made to a

Ik think I’m going to download the map (the Netherlands) again, maybe there’s a defect in the .img(?).

Best regards, Fred

It should work but dont rename gmapbmap.img because this background map is needed.
You can try to put the img on a external micro SD card (also in a garmin folder).
Or else analyse your problem with JaVaWa Device Manager:

Dear all,

Just downloaded and unzipped the OSM map for NL again, uploaded it on my Garmin, and guess what: it works (I can catch the map on the screen of the Garmin). Now get a little bit handy with the equipment ;). I guess there was a bug in unzipping the file (file had second time a bit less bites). I’ll rename the gmapbmap.img again.

Thanks for all!

Best regards, Fred