Foot path with bike access not routing

I recently fixed the path on this map next to Abbey Road DLR station in London, UK:

It now routes for pedestrians fine using GraphHopper, try flipping it to use “GraphHopper (Foot)”. It’s not routing over this path for bikes. Not until you move the dots a little closer together.

Did I do something wrong? Why does it prefer to route around via the road instead of this fine dual-use pedestrian-bike path? Try moving the drops around just a little and you will see you can get it to route over the direct route. Something is weighting it severely against this route.

Can someone please tell me what the proper way to fix this is or what I did wrong? Thanks.

Michael Grant

Interesting that for GraphHopper, it takes about 2 mins by bike the long way and about the same by foot along the footway. Maybe the penalty for a bike on a footway is to slow the bike to near walking pace. I notice that Bicycle(Mapzen) chooses to use the footway for a much longer length before going by road, but does vary a bit depending where you place start and end points too.
I see nothing wrong with your tags.
The database used by the routers is likely to be a little behind the Standard map at but because each of the above routers uses the footway they would seem to be using the same data.

I wonder if I modify the route from a Footpath that allows bikes to a Bikepath that allows foot traffic if this will be better. I’m going to try this and see what happens.

@mgrant, and what happens when you change the routing option to shortest distance in stead of fastest time? ‘Problem’ solved?
I think that changing way properties like you propose just for solving routing issues is not the way to go, off course unless the current tagging is clearly wrong. Just my 2 cents.

@BikePC, where do you tell the map to route for distance versus time? Maybe one of the apps let you do this but unless I’m just missing it, I don’t see that on the web map. At any rate, it’s difficult to imagine how the longer route could be shorter in time on a bike. On a bike, path along the tracks takes less than 1min to traverse at a normal speed.

So, some more info and the plot thickens! I modified the route to a bike route (with walking permitted) and… GraphHopper still does not want to route over the path preferring the road for bikes! However, now MapZen (Bike) now prefers this route taking only 1min.

But I agree, I should NOT have to turn this into a bike path for this to work. That would imply that every dual-use bike/walking path on the planet would need to be changed into bike paths by hand to fix this!

I’m starting to wonder if there is a larger problem with GraphHopper (Bike) routing is not working correctly.

Try it later, I guess the routing info from GraphHopper is not up-to-date and based on an older OSM planet extract. I don’t know how often this data is refreshed, better ask GraphHopper.

It’s in the routeplanner application or web-environment where you design your route based on the routing paramaters that the application allows you to set and using the ways on the underlying OSM-based map. Examples are Garmin Basecamp (local app.), (web app.), etc… The web map does not have the option to create routes.
Hope this clears up your confusion(?)

This seems to be solved now. See the related discussion here: … it is strange that the foot routing was changed quickly but not the bike routing as both happen at the same frequency.

Yes at GraphHopper Maps you can do this via adding weighting=shortest&ch.disable=true …