firefox on linux and windows cant move the map

Hello community,

I have the same problem on firefoxbrowsers in different operating systems. Other browsers dont have this issue on the same operating systems.

In firefox I cant move the map with left-click and moving the mouse. But I can zoome in and out with scroll wheel. And the issue only exists on (On it works). The mouse pointer over the map changes to a hand-icon, but left-click and moving the mouse around doesnt do anything.

Is this a known problem or a problem of my firefox-profile (cant remember, that I changed anything). Or am I to stupid?

Thank you, c64rockford

I don’t have any problem with moving the map with the mouse with left click on W10, FF64. Maybe your mouse settings?

I have no such problem with Firefox on Linux.

Is problem persisting with addons temporarily disabled? Is Google Maps also affected?

Hello, and thank you for answering.
No google maps are not affected, and works too.
Its only the page, which has this problem
Maybe I should check with a clean new FF profile…

A new firefox-profile didn’t help, its the same behavior.
I also tried different pointing devices (mice, trackball, touchpad on my laptop), no solution.

You can move with right or scroll button as well :). Doesn’t it work either?

Ok the problem is solved.

Linux works (with leftclick and with rightclick). Maybe I was wrong when I told you, that it doesnt work. It was my honest belief. Sorry for that.
Windows works too, when I exit my X-Mouse-Button-Control application, which helps me to map mousebuttons and scroll events on an old beloved PS2-Trackball. So it was my fault. Sorry for that too.

The only marginal difference is, that when moving with rightclick on linux the context-menu opens at the start (rightbutton down event) and on windows the context menu opens at stop moving (rightbutton up event). What is no problem at all.

Thank you for your help.