Etrex30 Map Deletion

I’m puzzled how to delete a map from an Etrex device’s onboard storage (SD Card not in context). ]
Not to disable the map, and not to replace the map with a very small tile depicting the Lake Vostok station.
I want this map DELETED!!! And I can’t seem to be able to do it :slight_smile:

Here’s the scenario:
-I have an Etrex30 which has onboard storage and an SD Card. Specifically:

  1. I presently use the SD Card for all map uploads
  2. When I was younger and dumber, I did update my internal storage a few times. Hence this post.

-Using MapSource, I have loaded the onboard storage with an OSM map using MapSource. Specifically:

  1. I downloaded an .exe version of this map from (
  2. Installed this map on my computer
  3. Modified the tile selection using MapSource
  4. Renamed the map to Japan_OSM
  5. Loaded this Map onto the onboard storage within the Etrex device. Once again, this map is called Japan_OSM.

-After much travel and having the great urge to clean-up my device, I tried a multitude of things in order to DELETE Japan_OSM. Specifically:

  1. I tried disabling Japan_OSM and this works. But this is not a DELETE!
  2. I tried replacing Japan_OSM with a much smaller and far-away tile. But this is not a DELETE!
  3. I tried deleting Japan_OSM by connecting the Etrex30 to my computer and browsing the unit as a storage device. Hehehehe and quickly found out that you can’t do that with an Etrex :slight_smile:
  4. I tried using MapSource and BaseCamp to delete Japan_OSM. Hehehehe and quickly found out that you can’t do that :slight_smile:

So, I’m stuck…and I want this map DELETED!!!

Is it really possible that the smart folks at Garmin have decided that a complete map DELETE is simply an underused function? lol

  • This is the normal way you should do it, so I wonder why you can’t? Can you see the map files in your file explorer/manager?
  • Try another USB cable
  • Try

-I tried using two different USB cables (One of them indeed failed to work…The Garmin original is the one which does work) on two different laptops. The same scenario across all equipment.

-I’ll try the software you suggested in a few hours and see what happens. Thanks here.

After days of mucking around, I realised that I had made a mistake in using the Windows installer and Basecamp as a method of pushing the open street map to my Garmin etrex30. I could never get the map to transfer at all.

Solution: Direct downloaded the zipped image file, inserted the SD into my laptop and created a folder called “Garmin”, and transferred the image file to the Garmin folder. Everything present and correct thereafter.