Error While Importing from GARMIN Nuvi 715 to Mapsource

  • I downloaded four maps: France, Switzerland, Austria & Italy from
  • Sent them one by one by Mapsource to Garmin Nuvi 715
  • Saved gmapsupp.img from each map
  • Merged these 4 .img files by “Gmap Tool” into one large 786MB gmapsupp.img
  • Saved this large .img file in /Garmin folder of the Nuvi 715
  • After turning on the Nuvi, this large map works fine. But importing this map from Nuvi to Mapsource faces this error:

“App: MapSource
At: 6/11/2010 9:59:40 PM (UTC)
OS: Windows 7 (64-bit)
Processor: x86, Processor Level: 6, Processors:2, Model: 23 Stepping: 10, RAM: 4193524
Products Installed:
Name: Trip and Waypoint Manager v4 (GRMN)
Id: 13303809
Version: 4.0
Type: Standard
Name: OSM World Routable
Id: 131072003
Version: 1.0
Type: Standard
Map: OSM World Routable (63240565) already exists.”

How this can be solved and merged map import to Mapsource?

I’ve never tried things like this, but guessing from the error: do you still have an OSM World Routable map installed in MapSource before downloading the map from the NuvI? If so, what happens if you remove that map first?

I uninstalled all 4 maps by an uninstaller program and then clean registry by a registry cleaner. Afterward “OSM World Map” disappeared from Mapsource drop-down menu, but this error again appears when i want to import joined map from Nuvi 715.
How this can be solved?

This might work:

  1. Extract the individual IMG files from the gmapsupp.IMG files using gmaptool.
  2. Use mkgmap with the --tdbfile option to generate a single TDB file for the combined map.
  3. Install in MapSource using MapSetToolKit.

All IMG files must have been originally made with mkgmap.