Downloaded map in JOSM does not match Alps in Oruxmaps

Hi everyone, allow me a short presentation.

I’m a mountain lover and just over a year ago I discovered the Oruxmaps application for android smartphones. I bought an android smartphone only to use this application, with the “Alps” map. I mostly attend the Dolomites, and in the Dolomites I am constantly looking for wild itineraries. Oruxmaps is useful to avoid, if possible, loss of orientation when the terrain is really difficult or the weather conditions become hostile. However, when exploring lost paths and forgotten tracks, I have almost always kept the recording of the route active. Now I have about fifty GPX recordings that include trail pieces that are not in the Alps map. I would like to contribute to enrich the map with these tracks, for the benefit of other wild mountain enthusiasts.

With this intent I installed JOSM in my PC, and following the instructions I tried to download a portion of the map to understand how to insert my tracks. Unfortunately I ran aground instantly because what I get from the downloaded map does not even remotely resemble the visible map on Oruxmaps.

This is the Misurina area on Oruxmaps:

And this is the same area on JOSM:

The paths are there, even if on JOSM they seem a little less precise, but for the rest there is nothing, only black background. No surveys, terrain type, level curves, most of the toponyms are missing. That of Misurina is a very beaten area, I took it for example because practically there the paths are all marked. In the wild areas, there are no points of reference. It is not possible to operate in such condition.

Surely I have done something wrong, or missed some settings. But after three days of studying the manual without coming to terms with it, I think I have to give up and ask for help.

Thanks in advance!

OSM does not have any height information except the odd peak, so the other information is being taken from alternative sources.

You seem to have downloaded the raw GPX trails as well as the map, which is why the paths are fuzzy.

Whether you see spot heights for the peaks depends on your View | Map paint style setting.

Oruxmaps seems to be a viewer for many different sets of map data, so one would need to know which particular map is in use. It is possible that there is a tile server for that map which could produced a background for JOSM.

Typically you would use one of the aerial imagery backdrops to aid in positioning.

If you want contours, you can use OpenCyclemap as a backdrop.

You can activate the South Tirol topo map layer to see contours and hill shading.

Thank you for the kind reply first of all.

I have installed in Oruxmaps this map: “Alps”, that I found here:
It is the first item listed.

ChristianK, the administrator of the site OpenAndroMaps, told me that those maps are based on the Openstreetmap database. So I arrived here.

No any other resource has been installed in Oruxmaps, and no resource is being used from the web. The phone has no data connection: I am using it as a GPS only. And it works fine.

I have done exacly what is indicated in the instructions of JOSM: selected an area, and dowloaded. I can’t figure how to prevent the download of the raw GPX trails. That’s not a main problem, anyway.

I see some peaks and I know the height of them. But I need full level curves at the minimum. GPS location is very good until you are on open ground or ridges, but in the gullies and especially along the walls or under vertical walls becomes inaccurate, very inaccurate!

For instance, if I have passed on a ledge, I know that the route can’t be where the level curves are congested. I correct the path of the GPS and put the way where the slope is moderate.

The map in use is the one cited above. For what I know and see, it is vectorial.

I hope you don’t mean Google aerial… :open_mouth:

How can be done this?

Thank you for your attention.

I have done it: activated the South Tirol topo map. Nothing happens.

I will repeat. The OSM database does not have contour line information. Any map rendering that contains contour lines is using more than the OSM database.

When you download with JOSM, there are two tick boxes, one for the OSM map and one for raw GPS data. You need to untick the second one.

I mean one of the aerial imagery options built in to JOSM. These are all licensed for use in tracing maps on OSM. The most commonly used is Bing. They do not release their oblique images to OSM.

To use OpenCyclemap as a backdrop, make sure it is enabled using Edit | Preferences | WMS TMS, then select it in Imagery. However, I imagine the more specific resource mentioned above will be better, if you can get it to work. I tried OpenCyclemap in your target area and it worked yesterday, although some tiles timed out and had to be reloaded.

You shouldn’t get nothing happening if imagery fails to load; you should get labels for each failed tile saying it failed to load. i wonder if you installed the configuration but did not enable that map layer. The page you were given assumes you know how to use image backdrops and just want to add one that is not in the standard list.


I also use OpenAndroMaps in the Oruxmaps application.

“Based on”, yes. Openstreetmap is the main source for what you see in OpenAndromaps. But not the ONLY source. Contours are taken from some other source and this information is included in the maps you download (so you don’t need a data connection). I think for Europe this source may be a dataset called EU-DEM but I am not sure of the specifics.

Have you been able to view any background imagery? If I go to this area in JOSM, in the Imagery menu I see PCN 2012 - Italy, as well as standard sources such as Bing, and Digitalglobe. That is without making any changes to my JOSM settings. Can you download any of these? That would be a first step to check before adding other backgrounds to the JOSM settings.

Assuming that works, you should be able to go into Imagery Preferences and activate the sources already mentioned (OpenCycleMap and South Tirol; OpenTopoMap is another one you might want to try). I tried all three in your area just now and they all work.