Do I need to disable original Garmin maps?


after loading the osm maps on my device, I see that both original maps and osm maps are checked under “tools / settings / map / map info”.

Do I need to uncheck the garmin base map? If not which one is using the device?


The Garmin Base Map normally shows only at countrywide zoom levels, so it’s good to leave it on. If you also have one of Garmin’s CityNavigator products on your GPSr you would probably need to disable it to see your OSM generated map.

Ok, thanks, I’ll leave it on.

But just to understand how it works:

I’ve got a nuvi 205 with italy map. What exactly means “at countrywide zoom level”? Are you telling me that the garmin map is used only while traveling between cities? And the OMS map it’s used while moving in a city?

thanks again

I’m asking becouse disabling the garmin map, and using only the OSM while moving in the city the nuvi gets confused and doesn’t route correctly. It just draw confused lines in the map (maybe I can take a picture if needed).

On the other hand, if I use a service like (which I think it uses the same OSM) the routes are ok.


Nuvis normally come with a routable map loaded. Handhelds don’t. The basemap I was referring to was for a handheld. Is the Italy map a Garmin map, and is it fully detailed? Can you zoom in and see block by block detail and street names if only the Garmin product is installed? Are you also using an OSM map of Italy? If so, why? Two routable maps of the same area could be really confusing.

Yes, the garmin map is filly detailed.

so it’s better to disable one…

I’d like to use the OSM map, but there is the issue I described in the routing. Maybe another version of the OSM map could solve the problem…

Definitely avoid having two active maps which overlap and where both contain routing information.

I don’t know the quality of Garmin’s Italian maps, but in the US, Garmin’s City Navigator NT is much more complete than the Census Bureau data that is used for the OSM maps of the US.

For just driving directions in the US, I’d stick with the Garmin map. If I need topo, trails, etc. I’d use a homemade map based on OSM data, similar to the Cycle Maps I’ve seen for Europe.

how do I disable the base map on a nuvi 1300? when I go to map info it only shows the OSM map. if I disable it and then view the main map screen it shows the base map. The base map of my area is very inacurate and with the OSM map enabled some of the base map does show through. when I drive on a major highway I see the OSM version of it which is dead accurate, but I also see the base map version of it which is nowhere near acurate and goes al over the place.

If there is no clear way to disable the basemap then the only option is to locate a ‘non osm’ .img & rename the extension (.img) to say .iii after making a backup on your harddrive.

Thanks wilpin, that worked. At first I couldn’t find any other .img file, but I found a file called garmindevice.xml under the folder Garmin which said it was in a folder called .system and therefor hidden. So on the root of the volume, in finder I went to Go>Go to folder and typed .system and then renamed gmapbmap.img to gmapbmap.old. I hope that might help someone else.

Anybody here know the DrawOrder for gmapbmap.img? I would have thought that it would be lower than any non-transparent map produced by mkgmap?

You can check this with gmaptool. Draw order = 0 on an old nüvi 310. I can’t rename this gmapbmap.img because otherwise the routing will break. OSM maps are not transparent, so i don’t need to disable the basemap.

That makes sense, so I wonder why Little Andrew is having the problem he’s having. Anything he’s loading should have a higher DrawOrder.

There are many more mysteries esp. with nüvi’s (and also other Garmin gps units) which dont work as expected with mkgmap generated maps. Holes in tiles, CN maps that cannot be disabled. Also this transparent behaviour of mkgmap generated maps comes back when you want to browse the gmapsupp.img in Basecamp (by connecting the device on your computer or using a SD cardreader).

Since I disabled my basemap the weird errors are gone, the routing works perfectly and for the first time since I loaded OSM roundabouts are working properly, I can only assume that it is something specific to certains models and possibly firmware versions. I am loving these OSM maps, my Garmin has never been so accurate and even where there are problems I can fix it and download a new map. With Garmin’s maps that just wasn’t going to happen.

I’d rather think that transparency problems are specific to mkgmap.
When you remove basemap from nuvi, you can get situation, where you can’t disable detailed map, like in described CN problem.
Usually above scale 5-12km, nuvi switches to basemap. When there is no basemap, it continues to use detailed maps and browsing can be very slow.