Displaying buildings and small areas in map

What needs to be done to have buildings and other small areas (like parks or landuse=grass) displayed in Garmin, please?

I am using mkgmap with the default style and this:

        --add-pois-to-areas \
        --add-pois-to-lines \
        --adjust-turn-headings \
        --check-roundabout-flares \
        --check-roundabouts \
        --code-page=1252 \
        --drive-on-right \
        --generate-sea=extend-sea-sectors \
        --gmapsupp \
        --housenumbers \
        --index \
        --latin1 \
        --levels=0:24,1:22,2:20,3:18,4:16,5:14 \
        --link-pois-to-ways \
        --location-autofill=is_in,nearest \
        --make-poi-index \
        --merge-lines \
        --min-size-polygon=8 \
        --name-tag-list=int_name,name,alt_name \
        --poi-address \
        --pois-to-areas-placement="entrance=main;entrance=yes;building=entrance" \
        --polygon-size-limits=24:12,18:10,16:8,12:4,10:0 \
        --preserve-element-order \
        --process-destination \
        --process-exits \
        --reduce-point-density=3 \
        --reduce-point-density-polygon=8 \
        --remove-short-arcs \
        --report-dead-ends \
        --report-similar-arcs \

I did with and without the default style (thinking that it might be related with it) and removing options that play with the geometry (like not using min-size-polygon, reduce-point-*, etc), but couldn’t have any buildings or small grass areas displayed.

Is this your map: http://naoliv.iq.unesp.br/mapas/ ?
I can see the buildings, but they are hardly visible (white, unknown area). You can try a typ file to make them better visible.
You can use the 2000.txt typ file that is used for the osm generic maps.

Another alternative is to render the buildings with type 0x10900 instead of 0x13 which renders them with nicer 3D like outlines (only on the GPS, not on Mapsource/Basecamp)

Right, will take a look at this typ file. Thank you!

Is there anything else that I need to use/include to also get small grass areas (landuse=grass) and leisure=park, please?

If you are using the default mkgmap style, leisure=park is rendered, but landuse=grass isn’t so you must adapt the style files and make your own custom style.

Copy mkgmap-rxxxx\examples\styles\default\ with all subdirs to your working-dir\my-own-style
And add --style-file=working-dir\my-own-style to your mkgmap parameters.