Different results with two Legend HCx when loading the same data

My son and I both have a Legend HCx. I update OSM data on his unit from time to time from my own files. My Great Britain data currently comprises the following three layers:

  1. British National Grid (courtesy of Roger Calvert) processed using mkgmap, incorporating my own .typ file
  2. Non-routing data from Geofabrik processed using mkgmap, incorporating my own .typ file
  3. Routing data from TalkyToaster.
    I usually use Img2Gps to upload the three separate .img files, which creates a gmapsupp.img file on the device. The British National Grid is a new item that successfully displays on my Legend, but does not display on his. That item also does not appear in his list of maps in Main Menu/Setup>SetupMenu/Map>Map Setup - Information. Just to make sure, I copied the gmapsupp.img file from my Legend to his, and the result is the same. Can anyone throw any light on this confusing situation? I apologise if I am posting in an inappropriate forum; perhaps someone could point me elsewhere if that is the case.
  1. Have you tried using either sendmap or mkgmap itself to create the gmapsupp.img file, instead of using Img2GPS?

  2. Have you tried breaking down the three files you are merging into different combinations to see what works and what doesn’t? You have three files that you are merging into one, so there are six combinations that you should try:
    BNG on its own
    Non-routing on its own
    Routing on its own
    What works and what doesn’t?

Maybe the two devices have different software versions?

I thank you for your response.

  1. Img2gps uses Sendmap.
  2. In response to your second question:
    BNG on its own YES
    Non-routing on its own YES
    Routing on its own YES
    BNG+Non-routing NO
    BNG+routing YES
    Non-routing+routing YES

My son’s versions are: Software 3.30, GPS SW Version 2.90
My versions are: Software 2.30, GPS SW Version 2.30

I expect this is the reason for the observed behaviour.