Deleted a multipolygon that needs put back immediately

I need help as soon as possible. Does anyone know how to revert something that was already saved? Or something? Yesterday I messed up really badly and deleted a multipolygon tag that completely removed a part of the Mississippi River. I’m typically really good about being careful so I don’t know how I even managed to do this. The lines for the polygon are still there but the tag was removed and i dont know what to do to get it back.

it happened yesterday at 3pm

Changeset is #69738778

PLEASE help me fix this, I hope this was the right place to ask.

i fixed it!!! lol, please disregard all of this

For all that might have the same problem - look at this:

for additional context: apparently my brain must’ve drifted off to sleep or something and i typed extra characters on a tag without realizing and hit ‘save’ because i fixed a couple other things along with it. so it said ‘multipolygon–’ instead of ‘multipolygon’. removing the two dashes fixed it completely.

just glad i noticed it now and not a week down the road or something like that

thanks for bringing this problem up.
I have to confess that in spite of being careful, a similar thing happened to me in South Java where I cut and re-sewed relation #447324, about 3 weeks ago :/. Luckily no other edits have been done on it since.
The changes are in changesets #69021306 or #69029460.
As I do not (yet) use JOSM, I´d be glad if someone could revert these changesets for me. Thanks :slight_smile: