Coastlines are not drawn in MapSource

I’m trying to draw coastlines in MapSource, but can’t get it to work.
Let me first try explaining why I want this. In Mexico (, there is a reservation area overlapping the sea. At certain zoom levels the coastline is not visible because of the lower drawing priority of the sea.
Adding the coastline solves this issue.

I have added coastline to my style (lines file) as:
natural=coastline [0x15 resolution 18]

I have added 0x15 in the TYP file as a thick red/yellow line as
Xpm=“0 0 2 0”
“1 c #FF0000
“2 c #FFFF00

I have checked that coastlines exist in the osm file
I have checked that I’m using the correct lines file (other line types do appear different when changed)
I do not know how to check that the .img file contains the coastline info.

Does anyone know what is happening, and what I should do to get coastlines drawn?

If you are using --generate-sea then I think it removes the coastline way…it certainly does it for the --generate-sea:polygons sub-option, and I have a vague memory that it also does for the --generate-sea:multipolygon sub-option too.

I’ve raised this before on the mkgmap-dev list but so far failed to rouse sufficient enthusiasm to get it fixed.

… just sent a mail to the mkgmap development list. I tried to create maps of Thailand, and the sea typically was missing in the bay between Phuket and Krabi (lots of islands there) and around. So I tried to get a coastline around these islands, but it always failed. Only when I removed the —generate-sea option, did I get the coastline.
Since Garmin does not provide any support to OSM, everything has to be found out by reverse engineering, and the sea seems to be a difficult thing. About a year ago, it was not yet available at all…

Thanks for the good tips. Removal of --generate-sea does the trick, but introduces other problems: no land. I now use --generate-sea with blue background. This generates a short of ok ‘sea’. Not perfect though.