Can't login on OSM wiki but can login on

I created a new account on the OSM wiki, I activated my email but I’m unable to login.

I saw that the sender from the mail was so I tried the login page on, my new account is accepted there without a problem and login goes smoothly.

I get the “Incorrect username or password entered. Please try again.” error when trying to login on the OSM wiki.

I copy-paste my password on both platform, that makes me 100% sure that my password is correct. Is there currently a bug or is login disabled?

I found the error.

Firstly I tried login with my OSM account, when that failed I clicked the “Forgot your password?” link. On that page I filled out my email adres and clicked “Reset Password”. On that page there is a text with a link “If you haven’t received an email, we recommend that you visit the reset password help page or try again later.”. I clicked the link to the “reset password help page” and ended up on the Wikimedia website where a created a new account.

In short, the OSM wiki redirected me to the Mediawiki where I created a account believing I was still on the OSM wiki.