Can't find the output IMG file from mkgmap

Not sure if I’m in the right area but after successfully downloading and installing one of Lambertus’s precompiled img maps (ca 7MB) to my Etrex 10 without any trouble, by copying and pasting files, I am ‘hooked’! However because this size of map leaves me almost no memory on my Etrex 10 to do tracking (I’m not into geocaching so no memory used there) I would very much like to do the same thing with smaller maps of <4Mb which I have exported from OSM, by converted them to IMG files with mkgmap but I have a problem…

  1. I have no problem selecting,exporting and renaming small OSM maps of <4MB.
  2. I can install and unzip mkgmap.
  3. I place the small map eg. testmap.OSM into the same folder as the unzipped mkgmap.jar.
  4. I have Java 7 Update 71 installed.
  5. I ‘run’ the command line ‘java -jar mkgmap.jar testmap.osm’ while the folder containing the two files is open.
  6. I see a brief flash of a black screen (say one quarter of my computer screen) but no output file 63240001.img appearing in the active folder.
  7. I have tried using IE snd FF browsers, three separate computers, OSM files as small as 0.3Mb, used both winzip and 7 Zip and switched off my Firewall, AVG and AdAware virus protection yet always get the same result. I have also searched my computer for the missing 63240001’img file but there is not one present anywhere.
  8. I have used file names less than 8 characters long.

My enthusiasm as a hiker to get as much out of my Etrex 10 and OSM as possible is really up against a brick wall. Can anyone make any suggestions, no matter how trivial or even insulting! they seem, so that I can get mkgmap working please.

Its probably a problem with how you are running the command. If using the run option, you would have to specify the full path to Mkgmap.

Instead of using the “Run” option in Windows, open a command prompt (probably on Start Menu > Programs > Accessories). You will have to change to the Mkgmap directory first (use ‘cd’). Then you can enter your command from there, and it will show any errors.
Note - you can hold down shift, and right click on a folder, and select “Open command window here”. That’s probably the easiest way to start with the prompt in the correct place. Then just use your ‘java -jar mkgmap.jar testmap.osm’. It will tell you if it works, or show any errors.

Also in Windows 8.1 you need to use “Command Prompt (Admin)” not “Command Prompt” or it can’t write the file to the disk. I don’t know about other version of windows.

To make it easier I made a batch file I named map.bat. In JOSM I save the file as map.osm. From “Command Prompt (Admin)” I type “map” and it runs Mkgmap. Below is the text of the batch file. You would need to modify it to the names and directory’s you are using.

cd c:\program files (x86)\java\jre7\bin
java -jar c:\users\dave\documents\gps\maps\mkgmap.jar --route --output-dir=c:\users\dave\documents\gps\maps\ c:\users\dave\documents\gps\maps\map.osm
cd c:\windows\system32

Thanks gents for your helpful comments.

Didn’t have any luck through accessing a command prompt, because XP didn’t recognise ‘cd’ and so I could not insert the path/directory?

I also tried the shift/right click approach to generating the command prompt at the right place but this didn’t work and on searching the internet I found that to make it work on my version of XP I would have to do some registry editing and I didn’t fancy that however…

I succeeded finally by using the start>run command, inserting the directory path to mkgmap.jar, then a space and then the java -jar mkgmap.jar testmap.osm when low and behold the img file appeared in the mkgmap folder.

Curiously I didn’t have any success either with the little programme offered by ‘nogonogo’ in this forum. I managed to get his programme compiled and apparently working (following the app’s footnote comments) but couldn’t locate an output file again. Any ideas where it might have gone?

One other question arose which was how much more difficult is it to reproduce my success with map areas which are somewhat larger than the rather small default ones on OSM export page. I couldn’t work out how to download even the simpler ‘Mapquest Open’ ones above this small area limit.