Can't authenticate maps. Contact seller... Solved

The problem: I have an Etrex30x ver3.0. Up now I have always downloaded map tiles from, installed them in Mapsource and used Mapsource to send the map to the Etrex. No problem. Recently I tried to get a current map from but the site provides only pre-compiled gmapsupp files that the etrex rejects with the message ‘can’t authenticate maps. contact . . .’

My solution: a) split the gmapsupp with the ‘Split’ option in Gmaptool (*see link below for instructions) and b) install the resulting *.img files using MapsetToolKit. At this point I can open Mapsource and carry on as usual. Problem solved.

Software needed:

  1. Gmaptool.exe
  2. cgpsmapper.exe (used with Gmaptool)
  3. MapsetToolKit.exe
    – with linux it works perfectly using wine


This process probably works with other devices that use similar firmware:
Oregon 700/750, Edge 520/820/1000, Etrex 20x, Etrex Touch 25/35, GPS Map 64, Montana 610, 680 . . .

Hope this helps

I just found a much better solution. Just reinstalling the firmware does it. I used MapInstall ver.4.2.3

Obviously unicode maps still trigger ‘Can’t authenticate…’ but that’s a different issue.