Cant add an imagery layer in JOSM

Hello all,

I’m trying to add a new imagery layer (Landsat 8) found here: I go on Imagery Preferences>add TMS and the past the URL for Landsat 8 into the 1st box and then the 3rd box. I give the layer a name and have tried both giving and not giving it a max zoom, and then click OK. When I select the imagery layer nothing happens except red writing appears telling me there is a ‘500 error’. Ive tried adding other imagery layers on that list with the same problem. What am I doing wrong?

Cheers, Will

Hi,{zoom}/{x}/{y} layer does work in JOSM version 7347

Click on the +tms button. Paste the url/address into Box 1 and Box 3. Enter 19 into Box 2. Enter a name into Box 4. Click OK. Then click OK to close the Preferences dialogue.

Click on Imagery in the Menu select your new image layer, it should appear in the layers box. NOTE you may have to zoom right out to see the layer as it might be to one side, then zoom in onto the layer.

Regards Bernard