Bounding boxes just aren't working for me

I’m trying to use bounding boxes to restrict a query for “France” to just the mainland.

The first variant below returns a syntax error. It doesn’t like “[bbox”.
The second variant below doesn’t restrict to the bounding box. It returns France and all its overseas possessions. What am I doing wrong?

out geom;
out geom;

So is not an option?

That’s a big improvement, but it still includes Corsica. Need a bounding box I think just to get the ‘mainland’

Does work?

Can’t find an existing boundary that works, so it might be something along the lines of:

area[name="France métropolitaine"][admin_level=3][boundary=administrative]->.mp;
area[admin_level=4]["ISO3166-2"~"^FR"]["ISO3166-2"!="FR-20R"]( ->.lhexagone;

All those tildes,^, !=, >, _ symbols have me complete;y bamboozled. I just used a bounding box (42,-7,51,8) and it solved the problem.

There seems to be something weird about the French-Belgium/Germany border. It’s rendering peculiar.


My query was rel[“ISO3166-1”=“FR”] with a bounding box of (42,-7,51,8)

Fixed it - my own silly fault. My bounding box just clipped the top and right edge of France. By expanding the box all is good. I struggled to find an easy way to generate the bounding box, but I’ve just worked out how to show the grid in Google Earth. I have the same issue with a few other counties, but I know how to fix it now.