bad/incorrect routing on garmin basecamp, recent issue

I think I already know the answer but if this is something I’ve done I’m stumped…

I’ve been using basecamp to route my hiking trips in basecamp and transfering to my dakota 10.
Ever since 1st oct, the maps have been acting oddly, giving me bad/incorrect routing…

Eg. would route my hike onto public highways/roads / route in straight line rather than following path / looping around/double back on path…

I’ve read on the forum it might be, among other things, my route avoidance, or profile (hiking/biking,etc…)

I downloaded from… I also tried deleting my garmin profile
%appdata%\garmin to see if I fudged the settings… and finally, I’ve re-installed the maps and garmin basecamp…

My guess at this point; it’s a compatibility issue between garmin / openstreetmap. (I can’t imagine garmin map format is opensource)
If thats not the case I’d love some more troubleshooting tips, suggestions on how to fix this issue. Its a little fustrating because I
use to the tool to calculate the estimated distance and features/landmarks to look out for/avoid…

I hope I’ve described the problem clearly. If you need anything else to help fix it (assuming it can be fixed), let me know


Some time ago I had the same problem in the nuvi and solved it disabling (renaming or deleting) the basemap.

Did you upgrade BaseCamp? There is a routing bug in BaseCamp 4.4.1 and 4.4.2. BaseCamp 4.4.1 was released on the 26th of Sept. so the timing is correct for your problem. BaseCamp 4.3.5 is the last version without the routing bug. I went back to it for that reason. If you upgraded uninstall BaseCamp and reinstall 4.3.5 or older

its mainly an issue on win7/basecamp… and I’d already deleted the basemap on garmin to save space…

that’s exactly right… so, I downloaded and installed the “legacy” version on their site (v4.2.5) and its confirmed… I hope there is a fix soon because all the previous data (tracks/waypoints/routes) are “locked” in the previous profile for v4.4.2… I don’t have another copy of the v4.3.5 installer, and the “backup/restore” function did nada/zilch…

I didn’t load 4.4.2 on the computed I use to make routes because I was warned that the bug wasn’t fixed. I did try it on my laptop but only created test routes so nothing I wanted to use. When I switched from 4.4.1 back to 4.3.5 my routes I created in 4.4.1 worked. I did need to open them and click on recalculate to get rid of the straight lines.

You can download 4.3.5 at I would download it and give it a try I think your routes will be OK.

If it asks to upgrade don’t let it.

Garmin BaseCamp v4.4.4 was released on nov20th… I saw this in the changelog, “Fixed autorouting issue where straight line segments were inserted after each waypoint”
… so far its working but I do have the backup installer just in case…

I also loaded BaseCamp 4.4.4 and the routing bug looks like it’s fixed. However I found all the routes, tracks etc I made after deleting 4.4.1 and reloading 4.3.5 were gone. I had to delete the 4.4 data base and reload the one from 4.3.5. Check to make sure you didn’t lose anything in the process.

I am using latest BaseCamp stable release for Mac (4.4.3 I think), with different maps, mainly (I load Norway, Portugal and Brazil for my own interest, several different options for Brazil). I am noting several different issues on routing. Some due to lack of data (when I identify the spot creating the problem I go on JOSM to make an edit effort on the local), and some appear more strange to me.

For example, the routing option “Avoid Toll Roads” doesn’t seem to be respected. I can understand from my home town to nearest airport, a 64km run have two toll road options, a non-toll-road option turns out 3 times longer. But when selecting other destinations I notice that it gladly passes a toll road instead of a 20 minute longer drive toll free.

Another issue I have noticed is that it seems not to accept long routing with Touring (car) or Motorcycle option, I have to select RV or Truck options for long routings, I have a few examples where I have test routes of 4000km (south of Brazil to north of Brazil) in order to check routing integrity. It also seems like selecting only “Fastest” or “Shortest” doesn’t affect much on the accepted length of the route, while adding “Avoidance” seems to allow for slightly longer routes. Chui - Fortaleza as Trucking-Fastest failed, while Trucking-Fastest-Avoid Toll Roads-Avoid Unpaved succeeded (though passing several mapped toll stations en-route)

My understanding is that BaseCamp 4.4.3 for Mac is about the same as 4.4.2 for Windows and has routeing errors. I’ve been told there should be a new version for Mac soon that has the routeing fixes that are in Windows 4.4.4 and seem to work. Garmin’s idea of soon and mine are not the same thing so I don’t know the timing.

yes. I would have lost many of the changes over the last couple months… restore didn’t work, and neither did restore from previous version… I had to make a duplicate 4.3 database and rename it to 4.4 and that seemed to work.

I share in your fustration that garmin left this routing issue for so long… I stopped using basecamp for osx because it didn’t seem as intuitive, and some maps are only availble with windows installer…

There is a new and long overdue release of Basecamp just out, v 4.4.6. I’ve used the routing function and it seems to work well. A friend also is reporting smooth, trouble free routing with v 4.4.6 (Mac) and my Windows version seems pretty solid.

Hope this one fixes the routing problems that have plagued Basecamp forever. There are any other things to fix but I’m happy about this release, so far.


BaseCamp 4.4.6 for Windows looks to have the same routeing fix as 4.4.4. But another routing error was discovered. If you have more then 1 point including via points and shaping points in the same segment (between intersections etc.) it will route from one point to an intersection then backtrack and go to the next point. This bug is in BaseCamp for Windows 4.4.4 and 4.4.6 I don’t know if it’s in Mac versions or older Windows versions.