Add a parent relationship, search in the field never works

Hi, I try to add a parent relationship (there 11807149 adding 2168105) but relationship search will never work (sometimes in other relationships, works)
Is there a trick ?

Which editor are you using?

In ID Editor an area where you know the relation is being referenced must be in view to see it in the list box. When doing a city bike charging sites relation (10 locations) I’d select the addition, then navigated to an existing member and then did the linking. It’s a painful experience in ID.

The main search bar lets you enter a node, way, or relation ID (optionally prefixed by n, w, or r, respectively) and navigate to it. This has the side effect of downloading the feature.

When you go to add a feature as a member of a relation, the relation search box only lists relations that a) have been downloaded and b) have at least one currently visible member. If a relation has been downloaded but isn’t currently in view, you can force it to appear in the list by entering its ID, e.g., r2168105.

By the way, this also works for relations that you’ve created but haven’t saved yet. For example, the first relation you create is r-1, the second is r-2, and so on.

There’s an old request for iD to keep every downloaded relation in the list until you save the changeset, perhaps sorting any out-of-view relations below relations currently in view, as in Potlatch:


Thank you! the ‘‘r’’ trick is working

Well, it’s bizarre because sometimes works well : the list displays and text search or 'r’xxxxx works too
And sometimes absolutely nothing appears on the list but the “New relationship…” .

I should’ve been clearer in my last post: sometimes you have to use the main search bar and select the search result to force iD to download the relation (so it knows about it) before you can search for it in the relation membership field.

If you’ve done that and it still seems to be unreliable, please open a bug report in iD’s issue tracker with details about what you tried. Thanks!

Do you mean trying to use that search ? It does not find whilst it does exist :

Here’s how to force an arbitrary relation to appear in the relation membership field:

  1. Without anything selected, type the relation ID into the search bar (with or without an r prefix):

  2. Click the relation that appears in the search results to download it:

  3. Select the feature you want to add to the relation, then click the :heavy_plus_sign: button in the Relations section and enter the relation ID (with an r prefix):

1 Like

Thanks, the problem is at the last step : nothing happens in the relations box.

Interesting, I can reproduce the same issue when trying to add Relation: ‪Linea 6‬ (‪11807149‬) | OpenStreetMap as a member of Relation: ‪Rete TPL Napoli‬ (‪2168105‬) | OpenStreetMap (after using the same search bar trick on both relations).

I have sometimes found it necessary to kick iD a little by editing the parent relation (such as deleting a member) and undoing the edit. Indeed, that seems to do the trick here. I wondered if it might be because a network relation has no bounding box as far as the OSM API is concerned, but it seems to work OK for other kinds of second-order relations I tried, like route masters and route superrelations.

Incidentally, there’s a request to make this dropdown work even if you don’t prefix the relation ID with r:

Okay, please keep me posted in the event of a resolution
Because it’s kinda painful …