Accepting vs not accepting messages

Discourse is supposed to allow inter-user messages. I have two accounts here - SomeoneElse and SomeonElse2, which is a test account that I created here to see what “basic trust level” looks like.

From my main account I easily see that I can send a message to the other one:

but the other way around it’s not the case:

Clearly there is some difference between the two accounts, but it’s not clear what. Under each profile page there are a plethora of links. There are lots of references to “email”, “notifications”, “messages”, etc., but it is unclear what setting controls the availability of that button or not.

To further confuse matters, for the “SomeoneElse” account, under “icon / preferences / emails” I see:

Screenshot 2024-02-23 121746

that implies to me that people ought to be able to send me messages, and that when they do, I’ll get an email.

From the “SomeoneElse2” account, I can send a message to “SomeoneElse” by starting to send the message to a different user and then changing the recipient to “SomeoneElse”. When I send the message I see this:

Screenshot 2024-02-23 122244

In this example SomeoneElse didn’t get the message, but in another case (a message from another moderator - I suspect that that is relevant) the same "… is not accepting messages … " error is displayed yet I both see the message in Discourse and I got emailed about it, just like the earlier screenshot said I would.

Obviously the “being told that a message was not sent when it was” is an upstream Discourse bug, but where’s the setting to turn on and off the message button in a user’s profile?

It looks like you have deactivated the receipt of private messages in your main account. Is that correct?

You can find the setting for this account here:


Yes - bizarrely, the tickbox for this is not under anything related to “messages”, “notifications” or “emails” at all:

It’s not exactly surprising that it was difficult to find.

I believe the names you have chosen for your users might confuse the system :face_with_monocle: