yahoo wms missing in updated version of josm -- windows

today I updated to the latest version of josm, and updated all the plugins, when i went ot load Yahoo arial data, the option was missing form the menu.

it was there last week, and worked perfectly, the only changes are:

I replaced josm-latest.jar with the new version;
I ran the auto updater on all the plugins.

the other 3 (comparitivly useless) options are still there.

any ideas how to get it back? google was of little help.

I deleted my preferences folder, and then put in username and password anew, and I downloaded all plugins anew (although I copied the file bookmarks, to the new preferences folder so I wouldn’t need to put them in one by one). This is what my WMS menu now shows:

  1. Landsat
  2. Open Aerial Map
  3. Yahoo Sat

One important change I did. In the preferences WMS tab down on the page where it says:
1 webkit-image {0}
2 gnome-web-photo --mode=photo --format=png {0} /dev/stdout
3 gnome-web-photo-fixed {0}
4 webkit-image-gtk {0}

Option 1 was chosen. I selected option 2. Then it worked for me.