Worldwide routable Garmin maps: URL REMOVED

Currently I use the Open FietsMap from for cycling with the gps.
When I create a route (not a track) I notice that since the july version there is a strange point in the Motieweg (Holten). In this point routing stops, both Mapsource and Basecamp don’t let you pass this point anymore. The road goes from tertiary to unclassified and a path connects in the same point.
Other OSM maps (like OMTB map) don’t show this problem. Only Open FietsMap does.
In Potlatch I can’t see what could be the cause. Joining the nodes didn’t help.
Any idea?

Hi GRI, I have corrected the node in the Motieweg at the point where the footway connects. The end-node of the footway was placed on top of the Motieweg node, but was not connected. Routing should be ok now, but may take some time before it is effective in downloaded maps.

Well, after working through thousands of lines of logging again (one map update results in 127.000 lines of logging :/), the source of the problem for Paris is found: When Splitter still cannot split the initial Paris tile in at least two subtiles using the parameter max-nodes=100.000 (remember: the initial split is using max-nodes=1.400.000!) the script simply gives up. Apparently Paris is the most complex area in OSM and the script is giving up too early.

Random other tiles are included as tiles for Paris because not everything is cleaned-up after giving up (especially the XML files that contain the tile definitions from the splitting action).

Phiew, finally! :smiley:

The necessary changes to the scripts are made (lowest max-nodes is now 10.000 but the change to the code wasn’t as straight forward as it looks). A new update is underway. Hopefully I didn’t introduce new bugs…

BTW, it would increase the speed of the rendering tremendously when Splitter could simply be ordered to output N files instead of providing a max-nodes parameter. This would eliminate potentially up to 23 split attempts on each initial tile (currently the initial split results in about 1900 tiles and the final result consists of about 2700 tiles).

I tried to download a map of BeNeLux, DE and part of France, from server osm2, which sends a mail fine that my request was queued but then nothing happens. It says I’m #0 in the queue but I get no confirmation that my map is complete. Then I changed the url to point to osm instead of osm2 and now I’m at #1 instead of #0 which looks more healthy, now waiting for a confirmation that it finished compiling my map.

For completeness URL’s of my request on osm2:
Resulting URL (refreshing the request in the browser showed the caching works fine, I got the same URL twice):

When I change osm2 to osm in the request URL I get the same queue URL except on server 1

[UPDATE] Finally got a confirmation mail from osm(1), which pointed me to a download location on osm2, which works fine, so I guess there is something wrong with the queue/processing on osm2, although it provides the files just fine.

Both servers are capable of generating each type of map (generic/openfietsmap and custom/country) but the website directs country map requests to server ‘osm’ and the custom map requests to server ‘osm2’. If you manually change the URL from ‘osm2’ to ‘osm’ and refresh you’ll get the same map but from a different server.

It is very unlikely that you got an email from ‘osm’ which points you to ‘osm2’ since the URL is hardcoded in the scripts. Can you forward the email including the headers to me?

When I request a custom map the osm2 server responds normally, so I cannot reproduce the behavior you describe.

However: routing over the Motieweg didn’t work (continuing from the tertiary part to the unclassified part). And only in Openfietsmap, latest 2 versions that I downloaded from
This sounds like another problem?

GRi, please read what Bikepc wrote:

The maps from are not rendered every minute, it may take a week (or more) before the next update is available, so please be patient.

@ligfietser, related to the correction on the Motieweg, I have a question. See the Dutch part in this forum.

Sorry, that was my mistake, I changed the url first, then copied it to my post, so requests to osm2 return urls on osm2 and osm to osm just as you said. However, I did 2 tries on osm2 and 1 on osm, but got only 1 mail from osm2 and 1 from osm, and then this morning one more that the request was queued and a download location (both on osm so I suspect you or someone else clicked my request, will remove my email from that post now). So either the mail server thought 1 email for 2 identical requests for the same email was enough (smart in a way) but then again, those 0 minutes took a long time :wink:
So to summarize: I did 3 requests and got only two mails the request was completed, but it did work in the end.

[UPDATE] I do notice a difference in the files on osm and osm2 by the way. osm does list a typ file while osm2 doesn’t. With openfietsmap this should be included automatically shouldn’t it?

Apparently not… I just noticed the following log messages:

Splitting nodes into areas containing a maximum of 200,000 nodes each...
Area (48.779296875,2.373046875) to (49.130859375,2.548828125) contains 3,126,220 nodes but can't be split further
1 areas:
Area 63242086 covers (0x22b000,0x1b000) to (0x22f000,0x1d000) FR-Montreuil

So Paris simply cannot be subsplit further to get tiles that are max. 8 MB large because the area of these tiles would become too small. The corresponding code in Splitter is (

if (densities.getWidth() < 4 && densities.getHeight() < 4) {
	System.out.println("Area " + bounds + " contains " + Utils.format(densities.getNodeCount())
			+ " nodes but is already at the minimum size so can't be split further");
	return Collections.singletonList(bounds);

So I’m trying to detect this situation in the script and -when encountered- ignore the 8MB limit to get (hopefully) a correct tile at least.

Lambertus, I remember a situation with a tile with the same issue, it couldnt be processed by mkgmap no matter how less nodes I used.
The fault was in a small way which was corrupt. When I left -ea out of the mkgmap parameters, everything went fine.
It seems you can split the tile Paris because the OFM tiles get rendered, so ignore the max size and just try to run mkgmap without -ea?

But I’m not running Splitter with the -ea Java parameter and the error + surrounding code is very clear. However I find it odd that some other Paris tiles are less wide and and others are less high:

At least the added cleanup stuff seems to be working as expected now…

The maximum tilesize for the generic map this is 8MB, for openfietsmap this is 23 MB. This difference is probably why the tile gets rendered in OFM.

Why are your tiles so small (8 mb), I know mkgmap can produce larger tiles (my largest OFM tiles are indeed around 23 MB, Full version).
Is that size intended for users with small internal memory devices?

Bingo! :slight_smile:

This was probably a glitch, not much I can do about it.

Yes, openfietsmap should include a typ file automatically. I’ll check for differences between both servers again.

Thanks for reporting!

Dear Lambertus,

I have downloaded the latest update (i.e. dated 2012-08-16) as I was very curious about ‘the hole in Paris’. I’ve been following the forum and I have to admit that I had the easy part in it … i.e. reporting. This version has my latest OSM updates (dated 2012-08-02), AND the hole in Paris has disappeared. It looks good. I really hope that the problem is solved.


Hi all,

First of all: Fantastic service, Lambertus!

Next: Sorry if my issue has been addressed before, but I have browsed through all 64 pages of this thread without locating the answer: I am trying to download a combined map of Denmark + Germany, but I think I might have hit an upper limit:

  • If I select Germany only: No problem (Germany is a cached download).

  • If I then turn manual selection on and try to add one (1) more tile, the server times out before responding.
    (The actual answer in Chrome is “Error 324 (net::ERR_EMPTY_RESPONSE)”)

I suspect that this is somehow a capacity issue, as the URL is both long and includes 253 named tiles. (Something like ``` [...] &tile253=63242712.img ``` ).

Is this a known issue? Is there a workaround?

Best Regards,


Sorry Jakob, an empty variable prevented the new update to be distributed to the custom map server. This is now fixed, requesting custom maps should work again.

Hi Lambertus,

If noone else has this error, of course it’s then an issue in my setup. It’s still there, and as I suspected the browser for mistreating the quite long URL, I have just tried with both Internet Explorer 8, Chrome 18.0.1025.162 and Firefox 14.0.1 with the same result:

When requesting a custom map with a lot of tiles in it (e.g. Germany and one extra tile = 253 tiles), the browser submits the request, waits for ~ 15-20 seconds and then responds that the connection to the server was reset. (Firefox states that the connection was reset “during download”, Chrome states that the connection was reset “by the server”).

I’ll continue locating the error (next step is to try the same from another internet location) and let you know.

Best Regards,


Strange, I just tried that (Germany+one extra tile) and no problem at all here. Hopefully you’ll find the problem (could be a firewall/virusscanner thing maybe?).

Hello Lambertus,

First of all, I would like to express my appreciation for the services provided through this website, fantastic! Last Friday I purchased a Garmin Dakota 20, the immediate cause being a holiday trip to Iceland. The Iceland map shows a fair level of detail, no doubt it will prove useful.

As a trial I downloaded maps for Netherlands, Belgium and Germany and made a trip today in the Ardennes and Eifel area. Although not as convenient to use as my Tomtom, the Garmin works quite well for car navigation, and the maps are fine.

One question crops up. I downloaded the maps for Netherlands and Belgium as a zipped .img, for Germany I got the executable for Windows. In the Germany map I can search a city, but not a street (using my GPS device) whereas in the other maps streetnames can be searched. Is there a way to enable street search in the Germany map?

Also, please could you list the differences between just copying the .img to the GPS device versus installing a map through the .exe file using Basecamp.

Many thanks,