Worldwide routable Garmin maps: URL REMOVED

ok any idea when I should try again, or what/where to watch for updates?

No idea, I always hope that services like this and generate a surge in software development. At least the latter one did that exactly. Splitter is maintained here:

Lambertus I think your work is awsome, you must be incredibly clever!

I’d like to see software that can grab data from an MP file and upload it to OSM. The map I’ve made using Mapedit is superior to the OSM one because it’s so much more user friendly.

Question, where do you see the future of mapping going and where will your own projects lead?



Lol thanks. But no, the people who develop Mkgmap are the clever ones here :slight_smile:

An MP to OSM converter? Just out of curiosity: What makes Mapedit so much better then JOSM then Merkaator?

Pff, difficult question this early. Well, I hope to see much more use of OSM data (why would we map anyway otherwise?). Mostly my projects appear at the time OSM is ready for it. E.g. the forum was introduced when OSM became also interesting to people other then geeks. was developed when The Netherlands, UK and Germany had fairly complete roadnetworks. The routable Garmin maps were a longtime wish but I refuse to do a lot of manual work each week so I waited until the tools had evolved enough to do the generation automatically. If other interesting areas to work on popup then I’ll do it (if my GF allowes it :P).

btw I assume the Mkmap people know about this coast line problem/bug, or do we need to report it officially?

oh and another request, is it possible to “name” the map so if I download two sets of maps
eg Korea and australia , they would appear separately on Mapsource
So when you build a Map you give it a name , I assume this can alter the registry entries you create right?
This could also be used in the filename too (I suggest keep the name small eg 10-20 chars

slight problem if I install two maps it looks like second map over rights the first Mapsource ?

so is this by design ie should I get ALL my maps in one shot or can I download two Mapsource install areas?

I didn’t know Merkaator existed and having had a bit of a play with it I’m impressed! So far I’ve been using Potlatch and JOSM, but Merkaator looks much nicer and is more flexible.

Question 1: I don’t understand what extract does, how do I convert GPX raw data into a track directly without having to trace it manually? (In Mekanator)

Question 2: When I zoom out on the raw GPX data the track quickly disappears, it’s a bit like looking at a road through a keyhole, can the raw GPX tracks be made visible at wider zoom levels? (In Mekanator)

Question 3: Could some sub groups be added to the forum index for OSM software? For example, Potlatch, JOSM, Merkaator, Mkgmap and a few others. At the moment all the questions are grouped together and it’s difficult to look through the answers to find what you’re looking for. I know there’s a search engine but it doesn’t always find what you want.



They know it. Someone else and I have reported it on the Mkgmap dev mailinglist.

It’s not the mapname that makes it unique within MapSource, but the family and product id’s. So if you want a new map to be registered under mapsource then you will have to give it a different id when building the TDB file. I could make this optionally configurable on the website.

All map tiles have an unique number so installing two combined maps from my website does not overwrite any maptiles. But MapSource uses the TDB file and overview image (63240000.img), which are unique for each download from the website, to show the map at a great distance and maybe also to know which tiles exist. This behavior causes MapSource to not show the previously installed tiles if you add a new set of tiles for a different area. So with the service at it’s current state you should download all the tiles you want in one go or use Mkgmap or MapSetToolkit etc to combine the tiles manually on you own pc.

Sorry that my questions encouraged you to ask these questions, but it’s best to start a topic in Q&A about this. I don’t want to go offtopic here.

Same applies here, this is a topic for the Feedback forum.

Update: The server harddisk was almost full last night so some large requests have failed partially (e.g. missing the mapsource installer). Sorry.

Thanks for a fantastic job.
I notice that the output includes a list of the tiles requested, would it be possible to be able to use that for an update in the future so that we don’t have to select the tiles again?

It is possible that the tiles get shifted or renumbered with each weekly split, so you might be able to use that list successfully again but those new tiles can also contain completely different data. This behavior is a result of the automatic tile size determination function of the Splitter tool I’m using for this job.

Selecting only a few tiles does not seem such a big deal to me, and I hope to pre-generate some continental scale maps for even easier downloading in the future (e.g. Europe, Asia, Africa, Australia, North/South America).

I downloaded Europe and everything is working well (except for the missing tiles). A few suggestions:

  • Why do some residential area’s show up on the map and others don’t? For example Guttecoven N51.013 E5.819 is visible, but Sittard N50.998 E5.866 isn’t…
  • I would suggest colouring forests green, instead of brown striped.
  • Buildings, which are white now, aren’t very well visible on the background.


first thanks for this service!

Now a bug report :slight_smile: I’ve requested a combination of several tiles. The request was processed quite quickly. However, mapsource crashes when the map is installed.

I have latest version of mapsource. My request id is ae6f2095d0cbad8d8b5d88c31702fdc2.

I don’t know. Perhaps it’s dependent on the population tag…

A few posts ago there was talk about adding a TYP file to the images or make it selectable to add a TYP file. I will look into that.

You’re welcome :slight_smile:

I have the same problem with that mapset with MapSource 6.13.7. I’m investigating…

Update1: It’s not a structural problem, as other mapsets work fine. So it’s probably an error in one of the tiles that’s causing this.

Update2: It’s tile number 63240138 (top of Scandinavia) which causes the problem, but I don’t know what’s wrong with it though.

Good, really no needed for me :slight_smile: I’ll try out another request. Thanks!

You can also just delete the 63240138.img file from the installation directory. MapSource will run just fine without that file.

Noticed maps do not show any data between E150 30.000 and E180 00.000. This means all of Sydney and surrounds and New Zealand are blank in MapSource unless you have a portion of map from outside those longitudes showing.

This occurs on all zoom levels.


Thank you for these maps. I tried it sucessfully on my Etrex Legend HCx. Thanks.
However, I have one question: how is it possible to define the place I want to drive to, not by pointing a place on the map, but by entering a street name?

Searching for streetnames is something that is just being developed in the Garmin map making tool Mkgmap. It just starts working in the last week so I haven’t been able to use that version yet. So keep and eye on the website and try again when new maps have been uploaded.

I see that Landuse=residential isnt rendered, in case of Guttecoven there is also a tag border=town maybe that tag is rendered and visible on the map. It would be nice to see landuse=residential will be rendered as well.

I have 2 more questions:

  1. when are the content of the tiles refreshed with new data from OSM? I tried to fix some bugs in my town, and I don’t know when they will be taken into account to check if the correction is ok…
  2. It seems that if I ask my GPS (etrex legend hcx) to guide me to a place in another tile (with respect to the one where I stand), the suggested route ignores the roads of the other tile but only takes into account the default set of highways defined in the coarse map built in the GPS memory. Is there a way to force a GPS to use the data from all tiles and ignore default coarse map data?

Aha, that I’ve experienced too. With a nuvi it takes the major motorways on the longer distances, even when I use the bicycle navigation option. Because you mentioned it, it’s the damn underlying base map (not the pre installed City Navigator, which I turned off) that takes this routing into account and there is no way to ignore it as far as i know :frowning:

I now removed the gmapbmap.img (basemap) from the internal memory, to prevent that it will take the routing into account, but it didnt help.
The only map on the Garmin is now OSM but still the motorways are chosen as the best cycling way :laughing:
So it is def. not the basemap who caused this, must be the routing software within the Garmin that is stupid.