Worldwide routable Garmin maps: URL REMOVED

Hi everybody, i have garmin 345 device and i have install maps for greece and serbia succesfully but i have problem with navigation. For example start from amfissa(greece) and nis(serbia) the end. The suggested route is not fit with the main layer road. What can i do for that? If i start from graz to nis there is no problem

Hey I feel a bit dumb. I make selection and the website continues to say (Make a selection first). I try the generic new style. What do I do wrong?

The service seems to be broken (again).

The button to generate a map is missing

I did not find any button to download the map, neither a place to write my email address…
Please help me.
Thx in advance.

If it’s broken I’d suggest downloading maps from somewhere else, such as those suggested at .

I tried bbbike : . Works fine for download but my Garmin states that the card is not unlocked. Garmin seems to block this cards. So i am looking for other free to download links.
Any ideas?



Any idea when the download link is back functioning?
Very good service, too bad it drops too often.

Please can you advise.
I have donated 15.00 euro and set up account,
I have selected maps for download.
can you tell me how to download gpx filres after selecting on map.

What gpx files do you mean? Where do you create/find them?

by default all generated Garmin maps from OpenStreetMap data will use
the code page Unicode (UTF-8). However, some older devices don’t
support Unicode and some new devices have a broken DRM firmware (“can
not unlock map”). In this special case please use the latin1 style.


I’ve tried multiple formats from BBBike and haven’t had any success yet but I’ll have another stab.

Is there a definitive answer to what the file should be called? I’ve seen both gmapbmap and gmapsupp in various instructions online. I actually have both on my device (edge 520).

gmapbmap.img is the Garmin base map containing only major roads and large cities. You should not delete this map (at least, if you have enough space on the device). gmapsupp.img is usually the name of the OpenStreetMap based map.

Hello all… I don’t understand why the link to download or the email request doesn’t appear to me :frowning:
Am I doing something wrong?


Hello everyone!!! I tried to download new version of garmin map from But in section “Request your map or download it directly” there is only info:“make a selection first” and no possibility of downloading map. Why is that?

You’ll have to select your map first (?)
I do select the maps but can’t download or do anything… :frowning:

Hello everybody,
I seem to have the same problem. No matter my selection (via tiles or by country) the site keeps saying I have to make a selection first. Using the optional ‘typ button’ MAPNIK makes the server looking for existing maps, but it stays looking, even after 10 minutes or longer. Does anyone know why this is (and perhaps solutions?)? Thnx Incantatrix

Hi, I also have the same problem. I select the maps and then where it says:- Request your map or download it directly:
(Make a selection first) I used to be able to put my email address in there and then wait for the two emails. Now I’m not given the option to put my email address in. Nothing happens. Last week was the same problem then it said the server was down so couldn’t get them and now we’re back to the same problem. Help!!


Yepp. Using the proposed settings it seems to work on my Edge 520.
Thx 4 help. Will donate.


I get the same problem…
Help please