Worldwide routable Garmin maps: URL REMOVED

And it is working fine now, Thanks.

I have been getting the message “Sorry, this service is currently not available due to server problems. Please come back later…” since last weekend. I gather this is an issue that pops up from time to time, but does anyone know when it will be fixed? I’ve tried different browsers and different computers but it does not seem to make a difference.


It’s broken, use a different site (there are lots that you can download OSM-based Garmin maps from). See GerdP’s post above and numerous others offering similar advice.

Isn’t there something missing from ? I don’t see where to put my email address, or how to download my selection, although I’ve successfully done this before many times in the past. Am I missing something obvious? David Reik, Farmington, CT, USA

Yes, seems the service is broken again. See previous posts for alternatives, e.g.

Hi Is anyone having an issue with some of the tiles the latest osm uk map. Some of them in the north of England do not display on my Garmin Edge when I zoom in closer than 2Km. I’ve tried both the pre-built uk map & a custom selection & neither of them work correctly. Cheers HD

This could be caused by multiple maps with duplicate tiles. Check it with Javawa Device Manager,

I only have the UK OSM map enabled on my device & none of the other maps have any UK tiles. It’s very confusing as the tiles I’m having the issue with are the tile covering my local area & another tile adjacent to it.

Other maps could have the same ID, they do not have to be enabled to mess things up. You can try to remove those maps to see if it gets better or try another map provider,

I downloaded the Javawa Device Manager & checked my device maps today. It did show that some of the disabled maps on my Garmin had overlapping tiles with my UK Map, though strangely there weren’t any overlaps in my local area where I’d noticed the issue.

I’ve removed the conflicting maps from my Garmin & the UK map tiles are now being displayed. I did think that if a map was disabled it wouldn’t have any effect on the enabled maps, but I guess my assumption was incorrect.

Thanks for you help in tracking down the problem. :slight_smile: HD

Good to hear that it solved your issue. Maps from different areas but from different updates can have identical map ID’s. So they don’t need to overlap the same area to cause a conflict. And as I mentioned, when they are even disabled, they still can cause conflicts with enabled maps.

I had the same problem when using Internet Explore. Switched to Chome and it started working for me.:slight_smile:

Question for UK Mkgmap experts … when routing from M4 South wales to the M5 West country, Mapsource (and the Zumo) refuses to use the M49. It routes through the Almondsbury interchange.
All avoidences are off, and shortest or fastest doesn’t matter, but if you add a shaping waypoint on the M49, its OK.
What is it about the M49 it doesnt like, as its clearly its the preferred route on the ground.
Is is the Construction Area that the M49 currently runs through, that throws it ?
(All works fine when using directions on the web based map). :confused:

Hi Russ, I’m not the expert you seek, but anyhow: my Zumo and Mapsource do this from time to time. I have never been able to figure out why and I simply put it down to bugs that Garmin couldn’t be bothered to fix. Happens on maps compiled with cgpsmapper as well.


To answer such a question an mkgmap expert needs to know all input to mkgmap:
The osm data , the style rules, and the options in use.

No issues here with the generic UK map from version July 19, are you sure you have the latest version?

Yes, using Generic routable (new style). 19-7-19.
The tagging looks OK for the motorways.
However, if I play with the slider in Mapsource, and set it all the way to the right (prefer highways, faster time), well Swansea to Exeter uses the M49 … but coming back it doesn’t !!
Strange… but no obvious answers so I won’t lose any sleep over it.
Cheers, all.

Ah, if I plan your longer route from Swansea to Exeter I can reproduce it. Maybe the router does not like this roundabout?

Hello colleagues! Is there a way to install and use several maps in Garmin Basecamp. It seems that the maps downloaded separately can’t get along with each other, probably because they have the same name. I was advised to install Mac OS gmap set as it doesn’t put any registry entries like Windows Installer. But it doesn’t help. Basecamp still displays only one map. Renaming via JaVaWa GMTK is not a remedy either. The map gets a different name only visually, but seems still retaining original name in one of its technical files.

yes, I have 6 different maps in Basecamp and I can switch between them.
I render my maps myself using different FID (File Identifier?) for the maps.
You have to change the FID of your maps to be different. I believe gmaptool does this.